1

TL;DR:

  • The USB is 8GB, it doesn't have any physical lock.
  • It is a goku doll and it was a gift for my friend, there isn't any brand. Chip Genius says that it is generic.
  • It is saying that it has 8MB and I can't restore it to their previous size or at least something that is not 8MB.
  • I can tell that this USB was able to store at least 4GB, as we used it to store a ISO without problems.
  • Even if it may be fake it wouldn't have 8MB, and we don't care if it is only 4GB or 6GB. We just want to make it usable again.
  • Data recovery is not a problem here, we have backup of everything inside.
  • I can't enter to the data inside the USB even if I make a partition via diskpart as Windows ask me to format it, and if I try to format it, Windows says that it can't finish the format.
  • I think that the USB is corrupted as I plugged it out when the Wii was stuck reading it without response. I'm not sure if it is truly bricked or it is still salvable.

I have a 8GB USB pendrive stuck to 8MB, the USB thinks that it is 8MB and I can't do very much.

What happened:

We were using it to charge iso files of Wii games to play in a fam's Wii. The Wii's homebrew app USB Loader GX wasn't reading the game (and actually there were two inside), but it was able to read before using it today. So I tried in the computer to check what was wrong, I changed the USB Loader in the Wii with another USB Loader And that USB Loader bricked the USB, when it tried to read the game, the wii just got stuck forever, I reset the wii and when I tried to check again what was wrong, but the USB was dead and I couldn't format it that version of USB Loader messed up the USB when I resetted or the USB was almost dying from before.

I tried almost everything to save the USB, first, this USB doesn't have any type of physical lock, it is just the head of a Goku's doll. I first supposed that the partition table was messed up (It somehow happened with a pendrive that I tried to use to format my PC and it just died by itself, something about partitions) Now a friend told me that it may be the firmware so, here is all what I tried to do

++ Windows 10 Solutions

Diskpart // It was able to clean the disk. Size: 8 MB Free: 8128 KB

Using Format // In capacity it shows Unknown Capacity File system: FAT (Default) Allocation unit size: Default Quick format ON.

I get the error Windows was unable to complete the format

Error checking tool // I just can't use it because it asks to format the USB and I can't.

CHKDSK /f /r // It shows this error

The type of the file system is RAW.
CHKDSK is not available for RAW drives.

Fake Flash Test v1.1.2 // I couldn't even test it.

FAKEFLASHTEST v1.1.2  [SSi]
DRIVE 2 -    7.0MiB Generic Flash Disk 2.0         
FFT - Quick Size Test (destructive)
F:                       DRIVE 2 -    7.0MiB Generic Flash Disk 2.0         

Writing marker blocks to drive 2
100% complete  - 0 min 1 sec remaining
Reading back marker blocks...
159% complete - 0 min 1 sec remaining
Memory tested in blocks of 25600 sectors.

BAD MEMORY from sector 16064 (7.0MiB) to sector 16064 (7.0Mib)
Test took 0 seconds.

                         *** FAILED ***

DEVICE HAS DUPLICATE OR BAD BLOCKS!

Recommended maximum usable partition size: -4.0Mib (approx. Last good Sector=16064)

Unplug and re-connect the drive, then reformat it using Windows or RMPrepUSB.

Chip Genius info // It shows me that it is a 32GB but is actually 8GB, not 32. Also that chip vendor and controller I couldn't find it online (Chinesse webpages showed up)

Description: [F:]USB Mass Storage Device(Generic Flash Disk 2.0)
Device Type:  Mass Storage Device

Protocal Version: USB 2.00
Current Speed: High Speed
Max Current: 100mA

USB Device ID: VID = 214B PID = 2060

Device Vendor: Generic
Device Name: USB2.0 FlashDisk
Device Revision: 1001

Manufacturer: Generic
Product Model: Flash Disk 2.0
Product Revision: 6.80

Controller Vendor: HuaYi
Controller Part-Number: HY6919
Flash ID code:      453C98B3 - SanDisk - 1CE/Single Channel [TLC] -> Total Capacity = 32GB

Hint: : Please exit this program and RE-PLUG your USB Flash Drive before you can operate it!

Tools on web: http://dl.mydigit.net/search/?type=all&q=HY6919


Possible Flash Part-Number
----------------------------
Unknown


Flash ID mapping table
----------------------------
[Channel 0] [Channel 1]
453C98B37672    --------
--------    --------
--------    --------
--------    --------

Flash Drive/Card Tester //

Read & Write does the same thing:

00:53:25.25 - -------------------------------- New test process started --------------------------------
00:53:25.26 - Started "Reading test data" for drive F: 7MB, "Generic, Flash Disk 2.0, 6.80, ", 512b
00:53:25.53 - Completed "Reading test data" for drive F: 7MB, "Generic, Flash Disk 2.0, 6.80, ", 512b
00:53:25.53 - Tested total 7.999MB in 0:00:00 with 31.768MB/s
00:53:25.53 - Total read errors: Fatal=0, Recoverable=0

Read Write and Compare starts to show errors, This is a fragment of the test as it is pretty long:

00:57:15.25 - ! Error in data at LBN = 240 (Off: 0h): expected 000401C0h, encountered 01FF01C0h.
00:57:15.25 - ! Error in data at LBN = 241 (Off: 0h): expected 000401C4h, encountered 01FF01C4h.
00:57:15.25 - ! Error in data at LBN = 242 (Off: 0h): expected 000401C8h, encountered 01FF01C8h.
00:57:15.25 - ! Error in data at LBN = 243 (Off: 0h): expected 000401CCh, encountered 01FF01CCh.
00:57:15.26 - ! Error in data at LBN = 244 (Off: 0h): expected 000401D0h, encountered 01FF01D0h.
00:57:15.26 - ! Error in data at LBN = 245 (Off: 0h): expected 000401D4h, encountered 01FF01D4h.
00:57:15.26 - ! Error in data at LBN = 246 (Off: 0h): expected 000401D8h, encountered 01FF01D8h.
00:57:15.26 - ! Error in data at LBN = 247 (Off: 0h): expected 000401DCh, encountered 01FF01DCh.
00:57:15.28 - ! Error in data at LBN = 248 (Off: 0h): expected 000401E0h, encountered 01FF01E0h.
00:57:15.28 - ! Error in data at LBN = 249 (Off: 0h): expected 000401E4h, encountered 01FF01E4h.

BOOTICE // This couldn't even do anything, I can't use any option of Process PBR, Process MBR is disabled. I tried to format the "8MB" drive with it using FAT32 and without optimized internal structure. It was successful but Windows doesn't detect it and ask me to format it... Also process MBR is now available but it doesn't do anything.

H2testw // Can't use it, it asks me to format the drive. (Error accesing target)

HP USB Disk Storage Format Tool V2.2.3 // It says Failed to format the device

RMPrepUSB V2.1.744 // For some reason it says UNMOUNTED, I tried all the tests and it always says

Cannot find drive 2
Please ensure you have specified DRIVE=n where n is a NUMBER not a letter!

and it crashes afterwards.

Check Flash V1.16.1 // It says: when I choose the USB. Any write and read test with default options with Use Temporary File:

File or device error: The volume does not contain a recognized file system.
Please make sure that all required file system drivers are loaded and that the volume is not corrupted

As Logical Drive

Test fail: Invalid handle.

As Physical Drive

File or device error: Access is denied

TestDisk v7.2 // I choose the problematic USB and "none", after that I choosed FAT32, after that nothing happened so I switched to NTFS, I pressed dump and it shows me an interesting message of missing operating system. Next I went back and picked "Analyse" and it shows me different partitions of what I think that it was what I did these last hours. (I tried it before but it didn't show anything to me) Check the gallery please. https://imgur.com/a/PgFgO1J

Linux Things // On linux I instaled in another USB Slax so I can use the terminal and try to fix it through Linux.

  • I used the command dd of=/dev/zero if=/dev/sdc bs=1M but nothing happened

  • I tried to use Gparted but it didn't work, it couldn't even make a partition table nor format it to make these 8MB accessible.

  • I tried to use fdisk and delete partitions but when I first tried it, there wasn't one

  • I tried Linux version of Test Disk but nothing happened too, also, when I first tried there wasn't any partition too.

I did almost everything that I could think and get in for, I just can't format it, I can't fix it, I can't update the firmware nor search it, I can't even wipe the info inside to start anew, I can't make it detect that it has truly 8GB and not that misery of 8MB and nothing. The most miraculous thing was when I tried to change the cylinders or heads on Testdisk and it changed from 8MB to 128~something, but I was in linux and I couldn't check if I can enter the USB as I'm not a Linux users. Also I think that I would mess it a lot more than it is, so I didn't touch it. Can someone help me with this or has an idea of what can I do? Thanks. I may be still trying something so some of the results from Test Disk will be different if I show them again.

  • Also I can truly tell that it may not be a fake drive, it truly is a 8GB drive and I was using it a couple of weeks ago for storing 7GB at least.
11
  • 1
    The DD command you tried in Linux reads the entire drive and discards the data, i.e., it does nothing. Basically it takes your drive as an Input File (if) and writes it to the Output File (of) /dev/zero, which is a virtual device which only outputs zeros and cannot be written to. Did you run gparted as root? Try using gparted (sudo gparted) to write a new partition table to the drive. Should be under the "Device" menu, pick the option that mentions creating a partition table. You probably want dos, not gpt, but either should work. – Layne Bernardo Jan 15 '20 at 1:22
  • PC Luddite - Thanks you for changes! I didn't check any rules here before asking for help. – Noutyr Jan 15 '20 at 1:23
  • @LayneBernardo The slax linux that I used doesn't have sudo installed, it has got bash instead (Also, I was booting slax from an USB) I installed sudo but I wasn't sure if I was with root permissions or not. I don't know how to check if I have them too. I'm going to try it again. – Noutyr Jan 15 '20 at 1:28
  • 2
    Does this answer your question? What can I do if my USB flash drive is write-protected or read-only? – Tetsujin Jan 15 '20 at 9:16
  • 1
    maybe you get a fake usb ? is it a genuine brand ? – Raymond Jan 17 '20 at 3:54
0

I was almost in the same situation and tried almost everything you did, but had zero success.

I think the problem with my usb-drive was in its controller: for some reason it reported wrong drive size. So, the last resort option may be firmware overwriting.

I tried this and it helped me to rescue my drive, but be very careful with these steps, because you can just turn your usb-drive into brick.

  1. Get your device vendorId and productId (VID and PID). Mine was 0951 and 1646. The simplest way for me was Linux lsusb command.
  2. Find a program which can rewrite firmware for your usb-drive. As I understand, it depends on it's controller model and version. Mine was Phison PS2251-50. I've detected it via search here. The detected program was MPALL v3.12.0A (for Windows).
  3. Download the program suitable for your device. Double-check that downloaded version supports your controller. The first version of MPALL I've downloaded contained an utility to read info about usb-drive. After I've dug into this info, I understood that I need another version of MPALL.
  4. Try to fill all necessary fields. MPALL has dreadful UX, better use an instruction for filling all the fields. I've used this one (it's in Russian, sorry, I found no English resources for that). I don't think other programs for this task have better UX.
  5. Upload a new firmware to your device.

I did it for the first time in my life, but my usb-drive works now. Hope this helps somebody. See also this article in Russian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.