0

Recently, I updated my Windows 10 box to the 1909 level. In doing so, it told me that my (older) VMWare Player was incompatible, and I would have to uninstall it. I did so, figuring I’d just get the latest free VMWare and install it afterward.

However, the installer for that version of VMWare reports that it is incompatible with my version of Windows, and will not install.

While I won’t have major conniptions if I have to rebuild my virtual Linux Mint box in a different virtualizer (it was only for ‘playing around’ and getting familiar with Linux), I’d rather avoid it if possible.

Is there a way I can get VMWare Player to install on Windows 10 1909, or is there some sort of fundamental incompatibility that can’t be corrected?

  • What specific error are you getting, and which precise version of VMWare Player are you running? On my Windows 10v1909 , I had 14.1.5 previously , downloaded and installed 14.1.8 successfully. – Christopher Hostage Jan 15 at 20:45
  • @ChristopherHostage - I was trying a 15.something install, but I don't recall the exact version. I'm not at that box right now. – Jeff Zeitlin Jan 15 at 20:46
  • The current version of VMWare Player is absolutely compatible with Windows 10 version 1909. Can you provide specific information on what version you are attempting to install? – Ramhound Jan 15 at 21:37
  • 1
    Does this answer your question? VMWare Workstation not opening anymore. While the duplicate question was asking about VMWare Workstation, VMWare Workstation Professional and VMWare Workstation Player are on the same release version. This means the answer to the duplicate question applies to this question. If you are getting a message that the version of VMWare Player you downloaded is not compatible then you didn't download 15.5.1 – Ramhound Jan 15 at 21:50
  • VMware Workstation 15.5.1 Player for Windows 64-bit Operating Systems. You will be required to log into your VMWare account in order for this link to work. – Ramhound Jan 15 at 21:55
0

Apparently, there was a pending reboot from an update that I never saw any notification of. When I got home last night, I saw that the computer in question had rebooted itself; I re-tried the installation of the VMWare I’d previously downloaded (since it was a version that supposedly works) with the intent of getting the exact error message to update the question with, and this time, the installation worked without a hiccup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.