0

I know it is saying that I should use python version in >=3.6, but the issue is here.

I am an offline user of Ubuntu 16.04 server and if I want to install any package I just download its wheel first and go as pip install package.whl --user or pip install package.tar.gz --user and done.

The last package I wanted to install was spyder-4.01-py3-none-any.whl that required tons of other packages to be installed. I did install every single of them till I stopped at flake8_2020-1.0.0.tar.gz which obviously needs python version in >=3.6.

Now I am little worried what will happen if I install python >=3.6 onto existing python 3.5.2. because I have been using it for a while and and all my packages work seamlessly.

I'd appreciate if someone could suggest a workaround for this.

0

I'd appreciate if someone could suggest a workaround for this.

You may want to try extracting flake8_2020-1.0.0.tar.gz and modifying setup.cfg, particularly the [options] section and python_requires line:

ex. original [options]

[options]
py_modules = flake8_2020
install_requires = 
    flake8>=3.7
    importlib-metadata>=0.9
python_requires = >=3.6

ex. updated [options]

[options]
py_modules = flake8_2020
install_requires = 
    flake8>=3.7
    importlib-metadata>=0.9
python_requires = >=3.5

You should then be able to re-archive the files and install your modified version (assuming you encounter no other issues).

In the long run, however, a better solution might be to consider looking into using virtual environments to test updated versions of Python and the modules you use, so you know when it is safe to upgrade.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.