My notebook's touchpad is not working properly and every 2 seconds or so it does a imperceptible movement that is only noticeable when I'm on fullscreen on any media player and it brings up the timestamp which is annoying me to no end. It only disrupts this activity so I only need a solution for when I want to watch something fullscreen without the timestamp flashing every two seconds.

Here's the problem: I can't find a single way to turn the touchpad off.

Fn+f1 works just for a second, but then touching the touchpad activates it again, and since this small movement is constant, it just turns on by itself.

I use a mouse and I tried "disable the touchpad when a mouse is attached", which does nothing.

I tried disable touchpad alltogether on the options and again, touchpad remains unaffected.

I tried synclient TouchpadOff=0. and it said

Command 'synclient' not found, but can be installed with: sudo apt install xserver-xorg-input-synaptics

but that command said

xserver-xorg-input-synaptics : Depends: xserver-xorg-core (...) E: Unable to correct problems, you have held broken packages.

And after trying to find a solution to that I accidentally screw with all my drivers and the notebook started to ignore all input (all mouse I plugged in, all keyboards, everything. I had to reinstall)

The touchpad still jiggles in cheeky disrespect.


  • The reason synclient isn't working for you is it looks like Mint moved from X11 to Wayland recently (in the last few years). I'm not too familiar with Wayland, but it looks like this article may be helpful for you. Specifically, section 3.4 - "Disable Touchpad". This is from the ArchWiki but the ArchWiki is useful for many more distros than just Arch. wiki.archlinux.org/index.php/Libinput#Disable_touchpad
    – Sam Forbis
    Jan 17, 2020 at 1:12

1 Answer 1


The most reliable method I have found is a simple script that I use:

> cat no-touch.sh

touch_id=$(xinput list |grep 'TouchPad\|Synaptics' |\
  sed -n 's/.*=\([0-9]*\).*/\1/p')
xinput set-prop "touch_id" "Device Enabled" 0

echo -e "\nDisabled TouchPad id=$touch_id"

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .