In IntelliJ IDEA Ctrl + Alt + L is used as a shortcut to trigger reformatting of the source code. Today I discovered that this shortcut does not work anymore. What happens is, that if I hit it twice the Windows session will be locked (just as I would have used Win + L.)

Has there been a recent change to the shortcuts in Windows 10? When I try to record this shortcut again in IntelliJ it is not recognized at all.

  • This doesn't happen for me. It might be caused by some product that you have installed. To verify, boot in Safe mode and see if this is still happening.
    – harrymc
    Jan 19 '20 at 21:53
  • How do I boot in safe mode?
    – Hannes
    Jan 19 '20 at 21:55
  • Google is your friend : support.microsoft.com/en-us/help/12376/…
    – harrymc
    Jan 19 '20 at 21:56
  • are you using a keyboard layout with AltGr? Because in Windows Ctrl+Alt is equivalent to AltGr which means you have to choose a different key combination
    – phuclv
    Jan 20 '20 at 12:20

Another software registered that key and is capturing it before IntelliJ.

Ctrl+Alt+L is known to be registered by:

  1. Windows 10, if accessibility is on.
  2. nVidia GeForce Experience
  3. Mouse without Borders

As you explicitly state that your machine locks if you press it twice I would go with Mouse without Borders as that shortcut is specifically tied to locking machines.

Notice the underlined DISABLE, it's a red-herring as you have to click on the actual shortcut and select "disabled" there!

enter image description here

  • 3
    Thank you so much, it was Mouse without Borders :-)
    – Hannes
    Jul 17 '20 at 7:03
  • 1
    Thank you so much, I been using Mouse Without borders for years and never realized it had shortcuts. Ironically the lock all mashines is the only one that makes sense :)
    – Griffin
    Mar 25 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.