0

TL;DR: I installed Android x86 on USB with main HDD detached. Now whenever I want to use that Android on USB, I have to detach HDD, else USB doesn't boot & says This is not a bootable device. I want to use Android while main HDD is still connected. Thanks.

Long story:

I installed Android x86 (LineageOS) on a USB flash drive, but before doing that, I had manually removed the computer's main Hard Drive. The USB drive was the only drive attached to the PC then (other than empty CD drive). Installation of Android worked OK, everything worked great, Android operated fine, etc. Then I reverted my system back to normal state, by removing the Android USB, and replaced my original HDD in the system, which now operates as normal with original OS in it (Windows).

Now the issue is that if I want to use Android again via that USB, it will only boot if that USB is the only one attached to the PC. That means I have to manually remove the HDD every time. If I keep the HDD in and boot the machine via USB (computer's boot device chooser menu via F12) there's an error This is not a bootable device.

So I would like to use Android in that USB while the main HDD is still attached. How should I do that (without having to reinstall Android LineageOS elsewhere as I have things stored in it and I have spent quite some time tweaking many settings and customizations etc)

Additional info (if useful): When I read the Android USB in Windows, it shows up as a drive labelled 'EFI' which has the following in the root:

\boot
\efi
\LOST.DIR
\Android
BOOTEX.LOG
startup.nsh

Thank you very much.

  • Try this : itsfoss.com/no-bootable-device-found-ubuntu – Madhubala Jan 20 at 19:30
  • Are you maybe trying to legacy (MBR) boot from the USB instead of EFI booting from it? – User025 Jan 20 at 20:20
  • @user52599 Does that work for USB installs too? – spcsLrg Jan 20 at 20:46
  • @User025 How do I find out? (Will the dir structure I noted above tell me?) – spcsLrg Jan 20 at 20:47
  • 1
    When you press F12 when you computer starts, you get a list of devices to boot from. When the name is the name of the actual hardware (something like WDBWLG0040HBK-EESN for example) then it normally means you are legacy booting. EFI devices have normally some descriptive name like "Windows Boot Manager". Some computers also group devices by legacy / EFI boot. A picture of your PCs boot menu would be helpful. @spcsLrg – User025 Jan 20 at 20:51
0

Here's how I finally fixed it:

I have Grub2Win now installed as my computer's boot manager. So all I had to do

  1. Labelled the Android partition on the USB as Android-x86 (Not the EFI partition on USB, Android partition on USB is the hidden one with the folder /cm-x86-14.1-r3/, you can scan and see all available partitions and folders to the PC via Grub2Win's boot menu)

  2. Opened Grub2Win under Windows, added a new boot entry, with:

Type: Custom code Title: Android x86 LineageOS Code:

set partlabel=Android-x86
getbootpartition  label  $partlabel
linux /cm-x86-14.1-r3/kernel root=/dev/ram0 androidboot.selinux=permissive buildvariant=userdebug
initrd  /cm-x86-14.1-r3/initrd.img

Now when computer boots with Android USB attached and main HDD connected too, there's an additional menu item in Grub2Win called Android x86 LineageOS and selecting it boots Android fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.