After updating my Centos 8 workstation, I got a black screen after booting to Centos, I suspected some problem with the graphics card, since I could ssh to my machine and everything else would work fine.

I installed the latest drivers from amd following the steps recommended by AMD to install the drivers. I've also checked that my card is in the "Product Family Compatibility"section.

I get a warning when installing, which makes me think if the latest drivers are not compatible with the kernel I'm running:

WARNING: amdgpu dkms failed for running kernel

Is there anything I can do, except running the version before my update?

System Info

  • Processor: Intel(R) Xeon(R) W-2145 CPU @ 3.70GHz
  • VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Lexa XT [Radeon PRO WX 3100]
  • "CentOS Linux release 8.1.1911 (Core) "
  • Linux 4.18.0-147.3.1.el8_1.x86_64 #1 SMP Fri Jan 3 23:55:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
  • status of the amdgpu or radeon kernel module:
    amdgpu, 19.30-909144.el8: added
  • status of modules, that contain "kms" or "drm", in the Linux kernel:
    amdgpu               3600384  0
    chash                  16384  1 amdgpu
    amd_iommu_v2           20480  1 amdgpu
    gpu_sched              32768  1 amdgpu
    drm_kms_helper        217088  1 amdgpu
    ttm                   110592  1 amdgpu
    drm                   524288  4 gpu_sched,drm_kms_helper,amdgpu,ttm
    i2c_algo_bit           16384  2 igb,amdgpu
  • UEFI boot is not disabled
  • Are you using UEFI boot or did you disable it? – xenoid Jan 21 '20 at 11:10

I fixed my Problem by

  1. uninstalling amdgpu driver by following amd recommendation on how to uninstall amd drivers: running sudo amdgpu-uninstall in terminal emulator.
  2. Updating to kernel version 4.18.0-147.5.1.el18_1.x86_64
  3. Installing amdgpu-pro-versionlist-19.50-1011208.el8.x86_64
  4. Rebooting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.