1

I have a Samsung NP300E4C laptop (AFAIK it has a Phoenix BIOS), it had Windows 7 installed, and I attempted to install Fedora on it.

I knew that Fedora would probably mess Window's boot. However, after the installation, the computer simply won't go past POST, it will shutdown and restart after 2 seconds, on a loop. It won't let me access the configuration screen F2 nor the recovery screen F4, even though it shows that it did recognize the keys being pressed (the POST screen shows "please wait..." when you press them). I can access the boot menu with F10, but both the Boot Menu and the App Menu are empty.

I have tried resetting the BIOS through the pins next to the RAM (AFAIK, it did do something, as the only item in the Boot Menu (Fedora) prior to that is now gone, leaving the list fully empty as it is now), sticking an USB drive, a DVD drive, and disconnecting the HDD. None have really made any difference besides the BIOS reset.

I have read that these models seem to have these kind of problems, though I haven't found a solution specifically to my case. I feel like there's got to be something wrong with the BIOS itself if it won't let me configure it even without an HDD.

UPDATE: Booting to an USB was possible by pressing F9. Thanks to harrymc's answer for the links to make custom USB images. After reinstalling Windows from an USB, the BIOS still doesn't work.

FIXED: Check this answer for links to the official BIOS update. In order run it in a Windows enviroment I had to use a live Windows USB, also the application needs to be connected to the Internet to download the drivers and then run them, so I also had to bring the wireless drivers; make sure you have them or have an wired connection. It didn't exactly update the BIOS, since I think it was the latest version, but I guess it reinstalled them, and after that I was able to boot normally. Thanks everyone!

8
  • Is this a BIOS vs EFI problem? Are you able to install Win7 and have that work? Commented Jan 21, 2020 at 20:20
  • @ChristopherHostage I don't think it is. But eitherway I can't boot into anything, so I can't reinstall Windows 7, or anything really.
    – ficion
    Commented Jan 21, 2020 at 20:23
  • Does this answer your question? Error notebook samsung np300e4c Boot menu is empty
    – harrymc
    Commented Jan 21, 2020 at 21:19
  • Even if you remove the hard drive, the BIOS will still not show up?
    – Sam Forbis
    Commented Jan 21, 2020 at 21:19
  • 1
    @SamForbis Yeah, concretely I can't go to the BIOS configuration screen.
    – ficion
    Commented Jan 21, 2020 at 21:27

3 Answers 3

1

Your BIOS seems to be very damaged, so needs to be re-flashed.

As the boot menu still works, the idea is to create a boot media in order to flash the BIOS.

I have not managed to find such media on the Phoenix website. If someone knows about such boot media, please put up an answer. In the meantime, here is my idea about creating it.

  1. Create a DOS boot media. See the How-To Greek article How to Create a Bootable DOS USB Drive
  2. Copy a Phoenix BIOS Flasher to this media. You may find one on the website of Wims BIOS.
  3. Boot from the media and flash the BIOS.
  4. If this fails, going to a repair-shop might be the next step (although perhaps too costly for an old computer).

The Wims BIOS website has also Windows graphical versions of the flasher. You will need a Windows-to-go boot media, which you may create as described in the post
Is it possible to put a full installation of Windows 10 on a USB flash drive?

4
  • Thank you, I hadn't seen this idea before. Unfortunately even though the Boot Menu shows up, I don't think it's actually working: it's empty, and AFAIK it should show the bootable media (even if they are empty), like USB HD, USB Floppy, USB Disc, Disc Reader. So I'm not even able to select USB in the Boot Menu, and I did try with a Fedora boot usb, Windows 10 installation usb and just now with a DOS boot usb... UPDATE: I was just now able to boot to the DOS USB by pressing F9...
    – ficion
    Commented Jan 21, 2020 at 22:11
  • Well, I spent some time using this way to boot into an USB to install Windows 10. I even cleaned all the harddrive, but after the installation, the BIOS is still doesn't let me do anything else. I know that your answer suggested to update the bios through one of those tools. Though I was able to launch it, I still need to have the rom file to do it, and I guess it needs to be exactly made to my board, else I'd risk completely bricking my BIOS, no?
    – ficion
    Commented Jan 22, 2020 at 3:59
  • @harrymc I think he checked off the wrong person's answer, it is you who came posted the real anwer, you just asked the community for a link, that's all. You deserve the +15 Points, not I.
    – vssher
    Commented Jan 22, 2020 at 19:05
  • @vssher: He can choose whichever one he likes, but yours was the last one that solved his last problem. I don't think he can upvote, so he can reward only one answer.
    – harrymc
    Commented Jan 22, 2020 at 19:41
1

@Harrymc per your request:


Series 3 Notebook NP300E4C

Firmware MAR 06,2012 | ver 1.0.0.3 | 2.12 MB

Trouble shooting guide
English

Source page: https://www.samsung.com/us/support/owners/product/np300e4c


There is also a software panel above this link which includes:
Recovery Solution, Version 5.0.2.7, SEP 20,2012, 104.94 MB
Recovery Solution, Version 5.0.2.4, MAR 09,2012, 104.95 MB

2
  • Thank you for the link. I had already seen it, but I had dismissed it before since I can't boot to Windows in the first place. However, I now realized I am able to boot from USB, and I had found a Windows 7 live image someone had posted in a thread related to this. Gave it a try, unfortunately this application needs internet connection, something which this small image doesn't seem to be able to do... I will try another method to try to launch some Windows from USB. Still, kind of a weird idea to require this kind of software to require a connection, huh
    – ficion
    Commented Jan 22, 2020 at 4:49
  • OK, this worked effectively. I realized I could just install the wireless drivers in the faulty live image, and I was able to download and patch the BIOS with this program. I don't think it much updated it as just reinstalled the same version, but either way it worked right away! I'm very glad for everyone's answers, though I'm not sure whose's answer I should mark as the right one, since I needed both yours and @Harrymc's. Thank you all very much!
    – ficion
    Commented Jan 22, 2020 at 5:50
0

Remove the power cord and battery, disconnect the hard drive, open the laptop and disconnect the cmos battery for 15 minutes, connect cmos battery back and plug in power cord only, see if you can get into the bios, if you can set the date and time before continuing.

Some models require complete disassembly before the cmos battery can be accessed, but may be your only chance to resurrect it.

1
  • As reinstalling Windows didn't seem to have fixed the issue, I think this will have to be my next and probably last resort. I will have to do it tomorrow once I'm able to unscrew all the screws (they are kind of old and are starting to bend). I'm not really sure how does the CMOS battery looks like in this computer, but I will have to guess. I've read it's more like the NVRAM got corrupted from the Linux installation, from other threads.
    – ficion
    Commented Jan 22, 2020 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .