3

Good morning.

Every night my Windows 10 PC wakes up, and thus wakes me up, at least once. Event Viewer shows the Wake Source as "Device - ACPI Wake Alarm". This despite my best efforts to disable ACPI wake alarms, and the fact that I can't find any active alarms.

Any tips would be greatly appreciated.

Steps taken:

  • In Power Management, I have set wake timers to "Disable"
  • In Security and Maintenance, I have ensured "Wake computer" is unchecked.
  • In Task Scheduler, I have taken ownership of the relevant UpdateOrchestrator tasks, and unchecked "Wake computer".
  • I have used Task Scheduler View to check that there are no tasks with "Wake to Run" checked.
  • Running "powercfg /waketimers" shows no active waketimers.
  • Running "Get-ScheduledTask | where {$_.settings.waketorun}" in Powershell shows two tasks, both in "Disabled" state.
  • Running "powercfg /devicequery wake_armed" shows only the mouse and keyboard.
  • I have even reinstalled Windows, just in case something weird was up with the old install.

I have referred to the following sources but after trying all the suggestions I am no closer to a solution

14
  • Are you sure there is no mouse/keyboard that wake up the PC? You can use hibernate before the problem is solved.
    – jw_
    Jan 22, 2020 at 6:37
  • Take a look at this page
    – spike_66
    Jan 22, 2020 at 11:31
  • What do you mean with "Reinstalled" exactly? - I have even reinstalled Windows, just in case something weird was up with the old install. - Did you installed Windows new and later used a safety copy of the old system or did you installed also all your required applications new on a fresh and independent windows installation? Jan 22, 2020 at 11:49
  • Yes I am sure no mouse/keyboard can wake the PC accidentally. That would show up in the event viewer. Also, hibernate does not solve the problem because ACPI wake alarms wake the PC even in hibernate. When hibernating the PC still wakes me up. :) Jan 22, 2020 at 13:57
  • By "reinstalled Windows", I mean I performed a fresh install. I did not restore a backup. Jan 22, 2020 at 13:58

1 Answer 1

4

The wake up alarm is due to the hibernating after sleep

  1. Open Power Options
  2. Change plan settings
  3. Change advanced power settings
  4. Change "Sleep" > "Hibernate after" values
  5. Goto sleep state
  6. Wake up
  7. Run in terminal: powercfg /SLEEPSTUDY
  8. Open created file C:\WINDOWS\system32\sleepstudy-report.html
  9. Find latest section (near the bottom)
  10. The diff time == the hibernate after time
2
  • This was my case. I think some update must have reset my power settings, because I had auto-turn-off screen and auto-sleep, and I never want these things to happen in my desktop PC. When I turned those off, I was able to turn off auto-hibernate too, and then my PC stopped waking up. Thanks!
    – msb
    May 13, 2023 at 3:42
  • That report is golden, thank you so much. It was driving me nuts, my PC was not going to hibernate after sleep it was already disabled. I found a log in that report for \HP\HP Print Scan Doctor\Printer Health Monitor waking my PC and now I need to violently murder some HP software. Dec 9, 2023 at 5:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .