1

When I try to delete the folder named C:\Program Files\WindowsApps\FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0 I get the error...

The file cannot be accessed by the system.

I tried to fix the issue by doing the following things with no joy. Nothing seems to be able to get rid of the folder! So from what I can tell there are no issues on the drive or with the system, I have full access to the folder and simply can't do anything with it! Does anyone have any ideas on what I can do to delete the folder?

1. I tried to delete it from Windows Explorer:

enter image description here

2. I tried to delete it from a command prompt:

C:\Program Files\WindowsApps>takeown /R /F FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0

SUCCESS: The file (or folder): "C:\Program Files\WindowsApps\FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0" now owned by user "DEIMOS\Arvo Bowen".

You do not have permissions to read the contents of directory "C:\Program Files\WindowsApps\FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0".
Do you want to replace the directory permissions with permissions granting you
full control ("Y" for YES, "N" for NO or "C" to CANCEL)? y
C:\Program Files\WindowsApps>del FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0
The file cannot be accessed by the system.

enter image description here

3. I tried to delete the folder in safe mode:

enter image description here

4. I ran SFC:

C:\Program Files\WindowsApps>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

5. I ran DISM:

C:\Program Files\WindowsApps>DISM.exe /Online /Cleanup-image /Restorehealth

Deployment Image Servicing and Management tool
Version: 10.0.18362.1

Image Version: 10.0.18363.592

[==========================100.0%==========================] The restore operation completed successfully.
The operation completed successfully.

6. I ran chkdsk:

C:\WINDOWS\system32>chkdsk /F /R
Checking file system on C:
The type of the file system is NTFS.

A disk check has been scheduled.
Windows will now check the disk.                         

Stage 1: Examining basic file system structure ...
  469248 file records processed.                                                         
File verification completed.
  8590 large file records processed.                                    
  0 bad file records processed.                                      

Stage 2: Examining file name linkage ...
  639 reparse records processed.                                       
  636680 index entries processed.                                                        
Index verification completed.
  0 unindexed files scanned.                                         
  0 unindexed files recovered to lost and found.                     
  639 reparse records processed.                                       

Stage 3: Examining security descriptors ...
Cleaning up 36 unused index entries from index $SII of file 0x9.
Cleaning up 36 unused index entries from index $SDH of file 0x9.
Cleaning up 36 unused security descriptors.
Security descriptor verification completed.
  83717 data files processed.                                            
CHKDSK is verifying Usn Journal...
  37844000 USN bytes processed.                                                            
Usn Journal verification completed.

Stage 4: Looking for bad clusters in user file data ...
  469232 files processed.                                                                
File data verification completed.

Stage 5: Looking for bad, free clusters ...
  77041071 free clusters processed.                                                        
Free space verification is complete.

Windows has scanned the file system and found no problems.
No further action is required.

 975651056 KB total disk space.
 666648388 KB in 331524 files.
    228852 KB in 83718 indexes.
         0 KB in bad sectors.
    609532 KB in use by the system.
     65536 KB occupied by the log file.
 308164284 KB available on disk.

      4096 bytes in each allocation unit.
 243912764 total allocation units on disk.
  77041071 allocation units available on disk.

Internal Info:
00 29 07 00 15 56 06 00 09 3c 0c 00 00 00 00 00  .)...V...<......
bd 01 00 00 c2 00 00 00 00 00 00 00 00 00 00 00  ................

Windows has finished checking your disk.
Please wait while your computer restarts.

7. I ran EaseUS Partition Manager looking for issues:

(RED blocks are bad sectors) enter image description here

8. I also tried to use WSReset.exe:

This did not yield any new results. The folder could still not be deleted.

C:\Program Files\WindowsApps>WSReset.exe
C:\Program Files\WindowsApps>del FocusHomeInteractiveSA.APlagueTaleInnocence-Window_1.0.5.0_x64__4hny5m903y3g0
The file cannot be accessed by the system.

As of right now, no known solutions have been able to help me delete the bad folder in the WindowsApps folder.

11
  • Taking ownership by itself is not enough to delete the folder. You also have to add yourself to the ACL, by default, Administrators and Users do not have the required permissions to delete a folder within WindowsApps. I have had success using WinZip to change the permissions on files contained within a folder contained within WindowsApps in the past.
    – Ramhound
    Jan 25, 2020 at 6:05
  • 1
    Does this answer your question? How can I free up space taken up by an incomplete Microsoft Store download?
    – Ramhound
    Jan 25, 2020 at 6:10
  • Does this answer your question? Editing/Creating files in C:\Program Files\WindowsApps
    – harrymc
    Jan 25, 2020 at 7:57
  • @Ramhound the takeown.exe application, I ran in the example above also sets new default permissions (ACLs) as well. I have included an image on #2 to show you. ACLs and Permissions are NOT the issues here. This has to do with Windows not being able to read the folder at all.
    – Arvo Bowen
    Jan 25, 2020 at 21:29
  • @ArvoBowen - Your hostility is unwarranted. Yes; Your reaction to the downvotes is unwarranted. Have you tried to navigate to the directory with WinZip ran as an Administrator and try to delete the contents of the directory? Having done exactly that I know it will work. Comments are not required to explain or justify a downvote. Most users would not agree with the explanation of a comment was required to issue a downvote. Hopefully, you will try my suggestion, instead of replying to this comment.
    – Ramhound
    Jan 25, 2020 at 22:52

3 Answers 3

1

You have to make sure that you also have full access on subfolders and files in the folder that you want to delete. You can try the following steps to take ownership of the folder, subfolders and files and then giving yourself full access to the folder, subfolders and files.

  • Go the the properties of the folder that you want to delete
  • Go to security
  • Click advanced
  • Click change near "Owner: "
  • Fill in your username and press OK
  • Check "Replace owner on subcontainers and objects"
  • Press OK on the advanced security settings
  • Press OK on the properties of the folder
  • Reopen the properties of the folder
  • Go to security
  • Click advanced
  • Click the add button
  • Click on select principal
  • Fill in your username and press OK
  • Tick "Full control"
  • Make sure it applies to This folder, subfolders and files
  • Press OK on the advanced security settings
  • Press OK on the properties of the folder

You should now be able to delete the folder.

1
  • 1
    I thought I left a comment on this a long time ago but I guess not. Just to leave a reason as to why I can't accept this as the answer I wanted to make sure it was clear that this is NOT a permissions/access issue. This has to do with an issue that is similar to a bad sector on a hard drive. Somehow Microsoft has locked down that folder and will not allow anything to change or even access it. The ONLY thing I could do so far to resolve this issue was to do a repair (removing all installed applications etc). I still have a ghosted drive (with the issue) of it to test other solutions though.
    – Arvo Bowen
    Feb 11, 2020 at 14:32
1

This happened to me also...
And these are the steps which solved my problem, hope this works for you too:

  1. Click on the "OneDrive" icon which is on the right side of taskbar.
  2. Click on "Help and Settings"
  3. Click on "setting" option.
  4. A tab will appear on your screen. select "Account" over there.
  5. Then click on "unlink the PC" .
  6. A dialogue box will appear , click unlink account on there.
  7. After that go to "system disk(c:) > Users > rauna" (in your computer ,location might not be same ,keeping "rauna" is my choice)
  8. There you will find "OneDrive" folder, delete it and those all files will be deleted which were showing error while deleting....
  9. After that again signin to your OneDrive account, your all data will be recovered from there and you will have whole access to them...
  10. If icons of some app are white then open "Task Manager" -find "windows explorer". do right click on it and select "end task " option...
  11. After that click on "File Menu" which will be at the top of "Task Manager" tab.
  12. Click "Run new task" and then type "explorer.exe" ,check the box and click "ok" ,your work will be done and icons will start to appear.
0

Why not try run as administrator at first? If you run as a user, your request for accessing to files may be rejected.

  1. Input "control panel" on the search bar and press "Enter" to open Control Panel window.
  2. Click "Change account type" under "User Accounts".
  3. In the pop-out window, choose the user you would like to change and click it.
  4. Then, click "Change the account type" on the left choices.
  5. Finally, tick "Administrator" and hit "Change Account Type".
  6. Restart your System and you will log in as an Administrator. Try again to check whether the issue is solved. If not, it's possibly because the file is corrupted, in such case, you can force delete the corrupted folders to fix the error.
1
  • My account was an administrator account. I also had UAC turned off. It was not access rights related but had to do with something in windows from what I remember. I think in the end I just formatted the PC.
    – Arvo Bowen
    Jun 27 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.