0

A few weeks ago I installed Windows 10 on my dad's, who still uses Windows 7, computer on an entirely separate SSD bought for that purpose. Immediately after install most of the taskbar and start menu is severely broken which as you can imagine went over great.

Symptoms

  • Pressing Windows key: Nothing happens
  • Left-click on start menu button: Nothing happens
  • Right-click on start menu button: Brings up the usual menu, but most option don't do anything
  • Left-click on apps: Does not work for the 4 leftmost apps (Microsoft Store, Email, Settings, Skype) but does work for the 4 rightmost ones (LibreOffice, File Explorer, Firefox, ...). I think this suggests I cannot open system files for some reason?
  • Right end of the taskbar: Only Keyboard Layout and USB Devices works, all others (including notifications and calendar) do not

What I tried

  • Installed all available Windows updates with no effect
  • Restarting explorer.exe in the task manager with no effect
  • This fix which said my system files were intact and failed with a write error (see below). This is despite the effect I ran CMD.exe as admin
  • I also did right-click to change permissions of the running CMD.exe shell (changed owner to Users and then gave full permissions to Administrator) but I get the same error
  • This guy suggests to use regedit but he's not specific so I cannot follow his instructions
  • I also can't open Edge, Settings, etc. from the CMD.exe command line (even as admin)
  • Creating a new admin user did not work, he also can't open the start menu

The write error was sadly in German, but it can be summarized as "failed to create directory":

Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073CF9, Fehler bei der Installation. Wenden Sie sich an den
Softwarehersteller. (Ausnahme von HRESULT: 0x80073CF9)
Fehler 0x80070003: Fehler beim Erstellen des Verzeichnisses für Systemmetadaten "C:\ProgramData\Microsoft\Windows\AppRe
pository\Packages\Microsoft.Windows.SecureAssessmentBrowser_10.0.17763.1_neutral_neutral_cw5n1h2txyewy".
HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]
110f2531-d39b-0001-4c67-0f119bd3d501, oder verwenden Sie die Befehlszeile Get-AppxLog -ActivityID
110f2531-d39b-0001-4c67-0f119bd3d501
In Zeile:1 Zeichen:94
+ ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

In summary

I think somehow I'm missing write permissions for system files as admin and read permissions for system files as user.

5
  • If after a clean windows install, windows is not working, why did you simply not reïnstall windows a second time? Sounds like something went bork during the install. I would reïnstall. – LPChip Jan 25 '20 at 22:53
  • I could do a fresh reinstall but it's time-intensive and I already installed all the apps etc. plus I have no guarantee this isn't gonna happen again – xjcl Jan 25 '20 at 22:56
  • I suggest you repair windows using a re-install. neosmart.net/wiki/windows-10-repair-installation/… Are you using a bootable media of the latest 1903 version of windows? A repair install will not change any applications. You can leave the existing files in their location. – Natsu Kage Jan 25 '20 at 23:02
  • You may wish to try a Windows 10 Repair Install to avoid reinstalling applications. Use the Microsoft Media Creation link for this: microsoft.com/en-us/software-download/windows10 – John Jan 26 '20 at 3:15
  • 0x8007nnnn errors the nnnn is a Windows error. Converting hex 3CF9 to 15609 decimal. So Net HelpMsg 15609 returns Install failed. Please contact your software vendor. See - winsourcecode.blogspot.com/2019/12/decoding-errors.html on how to decode errors. – Mark Jan 26 '20 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.