0

I have a very annoying problem - slow single-thread download speed. Surfing the Net is Ok, but when I try to watch a movie online (e.g. Netflix) it becomes suffering. I'm using Windows 10, Lenovo 330-15ICH with Intel AC-3165 wifi adapter. Also, I have the last Intel drivers installed. The problem remains from the start (as far as I remember).

Also, I'm using Dlink dir-822 router and it seems Ok on other devices. I've tried a lot of things - changing different drivers, disabling hidden protocols as mentioned here, deleting Intel driver and using standard one - nothing helps.

It seems to me, that the problem is on my side because other devices in my network work correctly. Here are screens from speedtest.net:

Really need your help, guys🙏😊

6
  • Hello there. You haven't mentioned anything about which apps you are using. Firefox, Chrome, Netflix App? Please clarify. Also, the single thread test is simply for the speedtest server and streaming quality. It has no direct link to netflix or anything else.
    – Natsu Kage
    Jan 26, 2020 at 22:26
  • @NatsuKage Hi, I'm using mostly Chrome and Firefox. Watching Netflix in browser this issue causes very low video quality (480p or so). Also, when I try to download one large file from browser it takes ages to complete (from different servers, even like Microsoft).
    – Secret-guy
    Jan 26, 2020 at 22:31
  • Just checking around....it seems like the Lenovo 330 has lots of wifi adapter issues. Have you tested with a USB wifi adapter or the likes? Or directly wired using RJ45?
    – Natsu Kage
    Jan 26, 2020 at 22:34
  • You might want to check this fix too: h30434.www3.hp.com/t5/Notebook-Wireless-and-Networking/… It says to uncheck "Allow computer to turn off this device to save power" in the device manager.
    – Natsu Kage
    Jan 26, 2020 at 22:39
  • @NatsuKage I haven't tried Usb wifi adapter because I don't have one. Connecting via RJ45 improves situation significantly. Your fix about allowing computer to turn adapter off gives me hope, will try it out tomorrow)
    – Secret-guy
    Jan 26, 2020 at 22:53

1 Answer 1

0

As per NWS106's instructions found on the HP support forums, this can be one solution:

The problem that I had was produced by Windows power management system. When I went just a few minutes without accessing the internet it would close down. I could have a browser window open, but if I was not actively sending or receiving data, the connection would shut down.

This is the two part solution (Windows 10):

PART 1

Right-click windows start menu

Select "Device Manager"

Open the "Network adapters" drop down

Right-click "Inter(R) Dual Band Wireless AC-3165"

Select "Properties"

Select "Power Management" tab

Uncheck "Allow computer to turn off this device to save power"

Click "Ok"

PART 2

Right-click "RealTek PCIe FE Family Controller"

Select "Properties"

Select "Power Management" tab

Uncheck "Allow computer to turn off this device to save power"

Click "Ok"

Restart the computer (don't know if it is necessary, but I always restart)

Success with this method may vary. Be sure to deactivate any third-party power management as well. There's always a chance the Wifi adapter is defective if this doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.