0

My windows 10 is on the Samsung m.2 Nvme ssd, I have some really imporatant files there. Now, I replaced my HDD drive (which didn't contains windows) with another, which already contains windows installed. The ssd was still connected to the computer with windows on it. I turned on the computer (with both ssd and hhd) and the windows of the HDD booted. I removed the HDD and tried to boot the Samsung m.2 Nvme, it's not working, it's not booting. It says that there is no operating system on it. The BIOS do recognize this Samsung m.2 Nvme. What can I do? Maybe it's important to say that I accidentaly activated Intel Rapid Storage Technology when I was in the bios, I disactivated it later. Is it matters?

2
  • I have Intel RST running on my ThinkPad with Samsumg SSD. Try resetting BIOS. Shut down, remove the hard drive, start BIOS, F9 to reset (check the reset function on your own machine), F10 to save and exit and restart. See if the machine starts. – John Jan 30 '20 at 1:45
  • If Intel RST has been disabled what exactly is your question? – Ramhound Jan 30 '20 at 2:51
0

I solved the problem. Apparently some of the windows files was in the HDD drive I disconnected, that's why the windows not booted. I just needed to connect the HDD drive back. Thank's for all the comments!

4
  • Ahah... Your computer bios sees the HD as 1st harddisk and the SSD as second. Even though Windows is installed on the SSD the bootloader is on the first disk. Unfortunately it isn't easy to fix this. Easiesy way is just to re-installl Windows from scratch while ONLY the SSD is in the machine. This forces everything to be installed on the SSD and you can re-instert the other disk later. Fixing it without re-installing is very complicated and not somethign that is easily explained. – Tonny Jan 30 '20 at 12:10
  • @Tonny Windows doesn't install the bootloader to the 1st available disk, it installs it on the drive Windows is being installed on. As to re-creating the EFI boot partition, it's relatively simple and does not require reinstalling Windows: Boot to WinRE > WIM the current EFI partition via DISM /Capture-Image > Create the EFI partition on the OS disk via DiskPart (shrink many need to be utilized before cre par efi)> Apply the WIM of the old EFI partition to the new one via DISM /Apply-Image > Delete the old EFI partition > BootRec /FixMBR && BootRec /RebuildBCD > Reboot – JW0914 Jan 30 '20 at 12:45
  • @JW0914 It does happen that the bootloader isn't on the OS disk. Especially with older systems installed with UEFI+CSM active this happens a lot. It is possible we are talking about a legacy boot here as well. That is why I meant to say it isn't simple. You need to do a number of checks to determine what is what. In case of a proper UEFI boot your methodology works, but I would never recommend it to anyone with doing a thorough investigation first. – Tonny Jan 30 '20 at 13:35
  • @Tonny Have you verified this actually happens with Windows 10, as I'm not aware of any configuration where the Windows 8 or 10 installer will place the bootloader (UEFI: EFI partition || BIOS: boot partition), on a drive other than the one Windows is installed to. Windows 8 and 10 shouldn't be installed with Legacy mode enabled on a UEFI motherboard unless the user wants a performance hit. Legacy [CSM] mode is intended for BSD/Linux OSes that don't have signed EFI loaders. – JW0914 Jan 30 '20 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.