0

My Network Setup consist of two Routers, one LTE Router (Router 1) working as a Gateway to the Internet, the other one (Router 2) working as Access Point in order to expand the network accessibility.

In addition, a RPi Zero running Pi.Hole acts as the DHCP Server of the Network.

Problem:

Within my network Setup, devices that connect via Router 2 don't get the correct IP assigned by the DHCP Server (DHCP Range: 192.168.1.100 - 192.168.1.250) but end up with 169.....s . Devices that connect via Router 1 get corrects IPs.

This Problem started when I introduced Pi.Hole as DHCP Server. Before that, Router 1 was acting as DHCP Server and every device got a correct IP. I can reach devices with wrong IPs via ssh and those devices even use Pi.Hole as Ad-Sinkhole but fail to communicate with its DHCP Server.

I'd appreciate every hint on why this is not working and if there's a possibility to get this to work.

Setup:

Router 1:

  • Model: Huawei E5186s-22a.
  • Firmware: 21.306.01.07.22 (Standard Huawei Firmware)
  • IP: 192.168.1.1
  • DHCP is deactivated.
  • This Router establishes the connection to the internet.

Router 2:

  • Model: Linksys WRT54GS Version 6
  • Firmware: DD-WRT v3.0-r40559 micro (08/06/19)
  • IP: 192.168.1.2
  • Subnet Mask: 255.255.255.0
  • Gateway: 192.168.1.1
  • Local DNS: 192.168.1.1
  • DHCP is deactivated.
  • This router works as AP and has been configured according to this Guide (Normal Version (Same Subnet))

Router 1 and Router 2 share one Wireless SSID but work on different channels.

DHCP Server:

  • Model: RPi Zero with PiHole installed
  • IP: 192.168.1.10
  • DHCP enabled:
  • DHCP Range: 192.168.1.100 - 192.168.1.250

Wiring:

  • There's a wired ethernet connection between Router 1 and Router 2.
  • There's a wired ethernet connection between Router 1 and the DHCP Server.
  • The DHCP Server connects to LAN 1 of Router 1.
  • LAN 2 of Router 1 connects to LAN 1 of Router 2.

Attempts so far:

  • Activating DHCP forwarding from the Router 2 to the DHCP Server --> No visible effect.
  • Setting the DHCP (192.168.1.10) server as local DNS on Router 2 --> Router 2 shows in the Pi.Hole's Log as Device . Beside that nothing changed.
  • Plugging the DHCP Server into the Router 2 --> Problem stays but now device connected to Router 1 end up with a wrong IP. Devices connected to the Router 2 get the correct IPs.
  • Connecting LAN 2 on Router 1 to the Internet Port on Router 2 but that did not change anything apparent.
  • I tried changing the wiring so that the DHCP connects to LAN 2 of Router 1 and LAN 1 of Router 1 connects to LAN 1 of Router 2. --> again no change

I`ve been running wireshark to look for DHCP requests.

Here's a device that ended up with a wrong IP trying to get something from the DHCP Server:

Number  Time         Source     Destination      Protocol  Length  Info
1108    133.580324   0.0.0.0    255.255.255.255  DHCP      378    DHCP Discover - Transaction ID 0x47de264f
1079    115.557997   0.0.0.0    255.255.255.255  DHCP      392    DHCP Discover - Transaction ID 0x46df78a0

I could not find any other log from this device with another DHCP message than DHCP Discover.

  • 1
    Does the RPi receive DHCP "discover" packets from clients? Does it send out offers in response? And does it receive the actual "requests" after that? – user1686 Jan 31 '20 at 16:18
  • Yes, Devices that connect via Router 1 get corrects IPs --> I just realised that I failed to mention this in my post and added this. – Peter S Jan 31 '20 at 16:26
  • Right, but I'm specifically asking about the devices which don't work... – user1686 Jan 31 '20 at 16:37
  • OK I did not get that. I'm not quite sure how I can monitore that but it seems like a good idea to get into that. Any advice on a monitoring tool? – Peter S Jan 31 '20 at 16:39
  • I added two lines from a wireshark log – Peter S Jan 31 '20 at 18:37
0

I solved the problem. It turned out Router 1 has a LAN/WAN Port. As soon as I plugged Pi.Hole into that Port, everything started working.

Working wiring: Pi.Hole connects to Router 1 on the LAN/WAN Port via ethernet cable. Router 1 LAN 1 connects to Router 2 LAN 1 via ethernet cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.