There are a lot of questions posted online and even on this site about the Windows 10 Delivery Optimization feature and its issues, but I unfortunately haven't found an answer for my situation.

My internet connection is 1 Mbps; yes, little 'b' for bits. When Delivery Optimization runs in the background, it hogs 100% of my bandwidth.

I previously had Delivery Optimization disabled in its place in the settings, which didn't actually do anything. I then disabled it by tweaking Services, but apparently Microsoft patched that particular fix. Now, no matter what I do, Delivery Optimization runs in the background unless I play whack-a-mole in the Task Manager to stop it.

So, if there's no way to force it to stop running, the option presented is to force it to use limited bandwidth. I have mine set as low as it will go at 5%. However, this doesn't use 5% of 1 Mbps, as it still uses 100% of my bandwidth to download updates. I have also set my wifi as a metered connection to no avail.

I have two suspicions: either Windows thinks my actual bandwidth is the maximum possible for the hardware connection itself (ethernet or wifi) which is in the 100s of Mbps or in the Gbps range, or Windows actually also has a minimum flat bandwidth value if 5% is too low (probably to stop people from gaming the system) which is at or greater than 1 Mbps.

What I need is to either force Windows to actually stop Delivery Optimization completely, or I need it to recognize that my maximum bandwidth is 1 Mbps and to use 5% of that for background downloads.

I would prefer not to use 3rd party programs, but I fear that might be the only option available.

  • Why not stop the whole Update service itself? If it's a WIFI connection you can also set up a metered connection to block it?
    – Natsu Kage
    Feb 1, 2020 at 3:14
  • The Update service restarts itself. I have also set it as a metered connection which apparently does not prevent it from downloading the update. Feb 1, 2020 at 3:18
  • I don't want to disable Windows Update itself, I just want to disable the Delivery Optimization. Mar 5, 2020 at 2:23
  • You've disabled delivery optimization in Settings>Update & Security>Delivery Optimization? And you're certain that's still what's eating your bandwidth? Mar 5, 2020 at 2:56

1 Answer 1


After trying to mess with Settings, Services, and downloading O&O ShutUp10 to try to fix the issue... it turns out that if Microsoft Store is updating an app (even if you have already explicitly told it to not automatically do that), it will use "Service Host: Network Service > Delivery Optimization" to do that.

If you, like me, have tried everything to get it to stop, check Microsoft Store and see if that's trying to update anything.

  • It's time to create a Unix & Linux profile on StackExchange! :)
    – WGRM
    Mar 7, 2020 at 16:48
  • Suggested workaround - superuser.com/a/1592658. Replace BITS with DoSvc.
    – Henke
    Nov 21, 2020 at 18:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .