4

I bought some JBL LIVE 650BTNC headphones and am trying to use them via bluetooth on a windows 8.1 laptop. The pairing works, but the sound quality is abysmal. This is not the case if connected via cable, or paired via bluetooth with my phone.

I read that the problem might be that the combination of mic + speakers are a bit too much for a bluetooth connection to handle without reducing sound quality. You can therefore find a multitude of recommendations to disable the "handsfree telephony" option in the device option or even just pick a different "non-hands-free" playback device - see here for an example for both solutions from superuser.

However, those don't work for me: in my playback device list, the headphones only get a single entry. And if I uncheck the "handsfree telephony" option (or deactivate the driver of the headset microphone in the device manager) the headphones just stop pairing with the laptop altogether and won't reconnect (until I re-check the option/enable the driver again).

It seems, for this model, the option for disabling handsfree talk is just not there? Am I therefore stuck with this bad audio quality when using bluetooth via my laptop?

EDIT (reply to commentbelow): I unfortunately don't have any other bluetooth headphones available for testing (might be able to lend some later this week).
Im not sure exactly how to check the supported Bluetooth profiles, but the Bluetooth device seems to be only supporting Bluetooth 4.0 (listed as "Bluetooth USB Module" in device manager). Laptop is an Aspire VN7-591G-77A9 (SNID 43902116066).

So maybe the laptop/bluetooth chip is simply too old to handle anything better?

EDIT 2: The accepted answer below worked out for me! My default driver was called Bluetooth USB Module - installing the suggested Generic Bluetooth Adapter fixed it for me!

Thank you very much for your help E.Nole!

2
  • 2
    1) Do any other Bluetooth headphones yield non-bad audio when connected to your laptop? 2) Which Bluetooth profiles does your laptop support? 3) What is it make of your laptop, and its parts model number? The latter is shown on your serial number sticker; other 'model' numbers don't provide the needed detail. Please click edit and reply to 1, and if 1) is YES, please also answer 2) and/or 3). Please do not use Add Comment; use edit instead. – K7AAY Feb 3 '20 at 18:42
  • Hello. I've rolled back your post to a previous version. We don't add Solved to question titles here - we're a Q&A site, not a forum, and we have a better way to do that: once an answer is accepted, like you did, the question is marked as solved. – gronostaj Feb 7 '20 at 21:37
5

I have a set of JBL Headphones too, though not exactly your model. I was facing similar issues as yours and coincidentally, just like you, none of the solutions from the thread you linked worked for me either. I also thought it was a hardware problem but that turned out not to be the case, at least for me.

To clarify, for me the issue was that when I connected the headphones to my phone the sound quality was perfect. On the other hand, when I connected them to my laptop the sound quality was noticeably lower. There were some audible high frequencies in some songs, in other songs the sound was somewhat muffled and tinny - almost as if there was some noise reduction being applied to the audio. It is a little hard to explain because the defects were quite subtle. But, in short, the sound was definitely not as clear as it was when connected to a different device.

What Worked For Me

First of all, I'm using Windows 10 and I believe my Bluetooth hardware component is by Realtek.

Back to the fix: it was actually a driver issue but hear me out before you say "Aaargh! Tried that already!". I'm sure you have already tried to uninstall the driver several times by now. I did too.

I realised one thing: whenever I reinstalled the driver, my laptop would still get the faulty one as the latest or best driver. So, after experimentation, I found the following steps fixed the problem:

  1. Unpair/Remove the Headphones

    I'll post the steps as reproduced on Windows 10, but I think some of them are the same on Windows 8.1.

    While the Bluetooth is still on:

    Windows Key → Settings → Devices → Bluetooth & other devices → Right-click on the device then click "Remove Device"
    (Will be greyed out if Bluetooth is turned off)

  2. Turn off the Bluetooth on the Laptop

    This is the first crucial step I missed when reinstalling the drivers the first few times.
    To turn the Bluetooth off, click the notification icon on your taskbar and then click the Bluetooth icon, making sure it is not highlighted. Alternatively, you can use the function keys or hardware switch if your laptop gives you those options.

  3. Go to the Device Manager

    One of the quickest ways to access it is by using "Windows + R" then type devmgmt.msc and press enter.
    Next, find and unfold the option that says Bluetooth. If your Bluetooth is off, there should only be one option under "Bluetooth". On my laptop, this option is Generic Bluetooth Adapter.

  4. Install the Local Driver Called "Generic Bluetooth Adapter"

    This is the second and final crucial step.
    From step 3...

    Right-click on Generic Bluetooth Adapter → Update driver → Browse my computer for driver software → Let me pick from a list of available drivers on my computer → Make sure Show compatible hardware is checked.

Now, there should be a list of drivers that are locally available (there were three in my case) and one of them should be Generic Bluetooth Adapter. Select it and install it by clicking next. After the installation, turn the Bluetooth back on, try to reconnect your device and see if the problem persists. If it is still not fixed, maybe at this stage try to disable "handsfree telephony". If this still does not fix the problem, repeat the steps but this time select the next driver on the list when you get to step 4 (if there was more than one option).

Hope that helps.

0

I have those exact headphones, and this is what happens to me: when you pair your headphones with windows you actually get two different output/input devices, one is the normal headphones (good quality) and the other is the hands-free headphones. You need to pick the one that does NOT say hands-free, and you do this in the taskbar, next to the clock. Check the images below:

Taskbar > Volume > Dropdown

And then just pick the one that does NOT say hands-free: (sorry it's in Portuguese)

enter image description here

Also, mind that there's a bug that happens some times when I select this option where no sound comes out of the headphones. When this happens, I just unpair and pair again and again until it works. Still trying to figure that out.

[EDIT] Also, you can deactivate the hands-free completely and it will no longer even show on that list. Maybe this will even fix my "no sound" problems I described above. In the device manager, look under "sound, video and games controllers", and disable all JBL hands-free devices:

Device manager > Sound controllers

(again, sorry for the Portuguese)

0

I had a similar situation of very poor sound quality on a quite different setup : JVC HA-S90BN headphones on GNU/Linux. I believe it may be relevant and helpful to post the solution here anyway.

In blueman-manager, by right-clicking on a device, one gets access to an "Audio Profile" settings.

Switching from "Headset Head Unit (HSP/HFP)" to "High Fidelity Playback (A2DP Sink)" greatly improved the sound quality.

Not the answer you're looking for? Browse other questions tagged or ask your own question.