I like using XTerm, I like its default "fixed" font, and I like using terminal colors rather than having a monochromatic terminal.

However, XTerm seems to insist on using a bold version of the font whenever it's displaying a bright color:


I hate the bold version of the font, but I like the brightness. The man page seems to suggest that adding "XTerm.VT100.boldMode:false" to my ~/.Xresources would disable this "feature", but it doesn't seem to have any effect. I've had it in there for months, so it's not a rebooting issue.

How can I force XTerm to always use the standard, non-bold version of the fixed font, even when it's displaying bright text?

Edit: Some have suggested putting "XTerm*boldMode: false" in my ~/.Xresources. That didn't help either. I've confirmed that the changes have taken effect with xrdb, though:

$ xrdb -query | grep boldMode 
XTerm*boldMode: false

If I run xprop and click an xterm, I get "WM_CLASS(STRING) = "xterm", "XTerm"" .. so I'm definitely running real xterms.

BTW, this is just a plain-vanilla Ubuntu Intrepid box. If anyone else here is running the same, can you try running:

echo -e '#\e[1m#'

...and let me know whether the # on the right has a black pixel in the middle like the one on the left does?


8 Answers 8


If you set the same font for bold and normal font it might work.

I set the fixed font for both like:

xterm*font: fixed
xterm*boldFont: fixed

If you then do xrdb -load and start a new term it was back to not being bold :)

  • 1
    – mike
    May 13, 2010 at 23:36
  • 1
    Is it normal for xrdb -load to take a very long time? I've been waiting for at least 5 minutes with no activity, and according to ps -e it's still running. Sep 15, 2015 at 3:46
  • @DaveKennedy Same issue here - does it ever finish? Feb 27, 2018 at 15:51

Setting allowBoldFonts property works for me

Add the following line in your ~/.Xresources

XTerm*allowBoldFonts: false
  • This works even when you use XTerm*faceName :-) Mar 14, 2014 at 16:47
  • This was the only solution that worked for me, probably also because I am using XTerm*faceName Aug 1, 2014 at 1:11
  • boldMode is about the emulation of bold style in a font that has none, whereas allowBoldFonts allows the use of a bold style available in the font.
    – Ant_222
    Mar 21, 2020 at 22:53

X resources aren't reloaded until you reload the X windowing system, and they aren't polled unless you restart the executable which is doing it. Try running

xrdb ~/.Xresources

in your current session. Then start another xterm. The next time you start X (relogin or reboot) the resources should be read automatically.

Another thing to try is to use a wildcard to make sure that it is picking up the resource correctly. Use

XTerm*boldMode: false 


Yet another thing to check is that you are actually running xterm when you run a terminal process. If not, you will need to change the fonts with a different resource.

  • It's actually been in there for months, so that's not the issue. I've updated the question to make this more clear.
    – mike
    Jul 29, 2009 at 21:13
  • edited to add more things that could be wrong.
    – jamuraa
    Jul 30, 2009 at 2:48

There's an XTerm resource specifically for this. Perhaps it didn't exist when the question was originally asked?

XTerm*colorBDMode: true

I found it necessary (on Lucid Lynx) to create ~/.Xdefaults-$(hostname). Omitting hostname made settings ineffective. ba's matching of font and boldFont did the trick of eliminating bold. xfontsel is a nice way to figure out what font to specify there. You can also start an xterm with something like xterm -font '-misc-fixed-medium-r-*-*-10-*-*-*-*-*-*-*' to test that your defaults are taking effect.


It's an xterm bug:


A temporary fix which works for me is to put the following cludgy fix at the end of your .bashrc file:

 echo -e "\e[1mA\e[2J\e[7mB\e[m\e[?5h\e[?5l"
  • Sadly, that doesn't help. I'm running XTerm(237), and that bug was fixed in XTerm(235). The echo statement didn't help either.
    – mike
    May 13, 2010 at 23:33

On fontsel-based system try xterm -fa Fixed. On my machine this fixes bold fonts, albeit the rendering becomes slower.


Check if the setting has taken effect:

xrdb -query | grep XTerm

If it is not in there, then you can force it to load:

xrdb -load ~/.Xresources

See the man page for more on this command.

  • It's actually been in there for months, so that's not the issue. I've updated the question to make this more clear.
    – mike
    Jul 29, 2009 at 21:14
  • You should check if it is loading anyway. If it isn't, your window manager doesn't do resources correctly.
    – jamuraa
    Jul 30, 2009 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.