3

I use Okular in an XFCE environment (archlinux). How can I set the default browser to use for opening URLs without installing a full KDE configuration panel?

As is, it does not use my default browser. From strace i believe it uses /usr/lib/kf5/kioslave5. I tried setting ~/.config/mimeapps.list as per this description:

[Default Applications]
x-scheme-handler/http=vivaldi-stable.desktop;
x-scheme-handler/https=vivaldi-stable.desktop;

To no avail. I also tried exo-web-browser.desktop.

Note that this question refers to KDE4, so I believe it does not apply.

To clarify: I have vivaldi set as preferred application / web browser as per the XFCE control panel. If I use xdg-open http://... it uses vivaldi. I do have two files ~/.local/share/xfce4/helpers/{custom-WebBrowser.desktop,vivaldi-stable.desktop}, both referring to vivaldi.

8
  • Try the answer in the last entry in this page. If it doesn't help, do you have Preferred Applications in the Xfce Settings Manager? Or xfce4-settings-manager? And why avoid installing the KDE configuration panel?
    – harrymc
    Feb 10, 2020 at 7:40
  • The xfce settings all point to vivaldi. I clarified the details in an edit. I would prefer to keep my installation as lean as possible, while I don't mind getting dirty with editing some files. I also don't know which Archlinux package contains the KDE configuration panel - so for practical reasons I would appreciate a hint in that direction.
    – Zulan
    Feb 10, 2020 at 11:45
  • The archlinux package seems to be xfce4-settings 4.14.2-1. If I understand right, you would rather not install it.
    – harrymc
    Feb 10, 2020 at 11:57
  • I do have xfce4-settings. I do not have the KDE configuration panel (package).
    – Zulan
    Feb 10, 2020 at 13:23
  • If you can open xfce4-settings-manager, then my linked answer might apply.
    – harrymc
    Feb 10, 2020 at 13:39

2 Answers 2

2
+100

(The full answer is given by the poster. This answer only details the links that pointed to it.)

The Ask Ubuntu post Clicking links in pdfs opened with Okular opens Abiword (instead of the default browser) contained the essential hint that Okular uses the file type of text/html, rather than html, so this was the one to look for.

In my comments above I also mentioned the utility xfce4-mime-settings that can edit these settings, which lives currently in the Arch Linux package xfce4-settings 4.14.2-1.

1

Using ~/.config/mimeapps.list / [Default Applications] was correct all along. However, Okular uses text/html instead of x-scheme-handler/http(s). So for me, it looks like.

[Default Applications]
text/html=vivaldi-stable.desktop;

This can also be edited with xfce4-mime-settings.

It appears that Okular specifically first downloads all urls internally and only then decides how to handle it as per the mime type of the document.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.