0

My laptop seems to be running infinitely faster whilst charging then it does when it's not charging for some reason.

My setup is an i7 9th gen w/ an RTX 2060.

I ran some quick benchmarks in Blender. While plugged in, an image renders in about 40 seconds. However, when I unplug it, it takes upwards of 3 minutes to render! (I'm using my graphics card for these benchmarks).

Here is the original, more detailed post. Please note that while the wording of that post is tailored towards Blender, my laptop is just faster overall while plugged in, period.

Why is this and how do I fix this?

I hypothesize that this is because of power allocation. Maybe the processor and graphics card combined are taking more power than the computer is willing to give. However, I don't know how to change this. I'm not too well educated on this topic, so is this even possible? Thanks.

EDIT:

Someone has brought to my attention that my batter performance-mode might be set to better battery life. I can confirm that I always make sure to set it to Performance on startup, if it's set to something else, regardless of whether it is charging or not.

Battery Mode

EDIT 2:

A lot of people seem to be suggesting the fact that my apps might be using the integrated graphics when the laptop is not charging. I have already configured apps I frequently use (such as Chrome) to use the High-Performance Nvidia processor from the NVIDIA Control Panel. Aside from that, Blender, the benchmarking app, gives an explicit option to choose between rendering on the GPU or the processor. I have chosen the RTX processor (GPU) already and the problem persists all the same.

Cycles Render Settings

  • Look at your performance settings if you are running Windows. There are different settings when running on battery power (designed to conserve your running on battery time). – DavidPostill Feb 6 at 18:50
  • 1
    You might have to specifically force Blender to use the GTX instead of the UHD graphics: pureinfotech.com/set-gpu-app-windows-10 – Natsu Kage Feb 6 at 18:56
  • @NatsuKage Yes, I have configured apps I frequently use (such as Chrome) to use the High-Performance Nvidia processor from the NVIDIA Control Panel. Aside from that, Blender, the benchmarking app, gives an explicit option to choose between rendering on the GPU or the processor. I have chosen the RTX processor (gpu). – Arihan Sharma Feb 6 at 18:59
  • Try setting it in windows as well, just in case. Also, you haven't mentioned the model of your laptop nowhere. Have you checked for a specific issue with your model? It's possible your power is automatically limited in battery mode: because the battery isn't powerful enough for your internals. An i7 and a GTX 2060 is a lot of power. – Natsu Kage Feb 6 at 19:18
2

The answer has already been given here:

Why are my games slower on battery power, even with the power plan set to High Performance?

Running a high-performance GPU at full speed while on battery can damage the battery or require more power than the battery can safely supply.

A laptop with a mobile i7 and a RTX 2060M together can use over 150W at full power. That's more than most batteries can safely give.

| improve this answer | |
  • Thanks, that explains it. Although it does bring up the question, is there not a way to override this default security precaution? No point in buying a heavy-duty laptop versus a desktop-workstation if the portability and performance can't go hand-in-hand. – Arihan Sharma Feb 6 at 21:28
  • The portability is that the desktop power is mobile-ish. The computing power of the high end laptops is not meant to be had without the power supply (or 2 power supplies in some instances, my lapish-top from origin can draw 500w under load) It take a lot longer to haul around a desktop, all the cables, mouse keyboard and monitor, than it does a high end laptop and it's power supplies. That being said, between physics and safety against exploding batteries, i doubt there is a way to make more power appear from the battery than what the hardware/os allows. – Antony T. Feb 6 at 21:43
0

Windows 10 may have different battery saving and power options depending on whether it runs on battery or not (for example, HDD stops earlier). Win10 still has two setting windows: UWP and classic. Choose "Best performance" in all of these.

Also, check your UEFI settings and the manufacturer-provided setup utilities like Fan Control etc.

| improve this answer | |
  • Thanks for your answer. As the edit to the post suggests, I make sure that the battery mode is always set to Best Performance. – Arihan Sharma Feb 6 at 18:54
  • 1
    That part appeared after I sent the answer. Also, check our BIOS settings. – homocomputeris Feb 6 at 18:56
0

If your laptop has a dedicated GPU card then it probably is getting disabled when the laptop is not plugged in and its switching to your integrated GPU rather than the Dedicated.

As integrated GPU's tend to not preform not as well as a Dedicated GPU you don't want this behavior to happen.

There is a few ways to do this either via using windows power options and selecting performance, or by going into your graphics card control panel, and going into its power management and making sure its set for maximum performance.

Try referring to this post here

Do note that switching these settings will significantly impact battery performance when it is not plugged in, and battery life will generally be shorter day to day.

| improve this answer | |
  • Thanks for your answer. Yes, I have configured apps I frequently use (such as Chrome) to use the High-Performance Nvidia processor from the NVIDIA Control Panel. Aside from that, Blender, the benchmarking app, gives an explicit option to choose between rendering on the GPU or the processor. I have chosen the RTX processor (GPU). – Arihan Sharma Feb 6 at 19:10
  • You could also try a different method, you could try to hit Windows key -> settings (the cog) -> system -> display -> scroll down to the bottom -> graphics settings then you can add a classic app (or universal) and set it per app to be high performance or power saving. – SomeRandomOwl Feb 6 at 19:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.