I am developing on Rails5 with jQuery. All of a sudden, this afternoon, I started getting these messages in my DevTools console. It happens even running DevTools under StackOverflow. I cleared cache, restarted the browser with no change.

Searching for a solution, I ran across 44315460 When do browsers download sourcemaps? but I don't even know what to do with that.

OBTW, clicking on any of the links generates "ERR_FILE_NOT_FOUND".

I have no idea how this started nor how to fix it. Advice?

DevTools failed to parse SourceMap: chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/sourcemaps/onloadwff.js.map
DevTools failed to parse SourceMap: chrome-extension://gnldpbnocfnlkkicnaplmkaphfdnlplb/ContentScript/CustomisedWorkItemMessaging.js.map
DevTools failed to parse SourceMap: chrome-extension://gnldpbnocfnlkkicnaplmkaphfdnlplb/ContentScript/CaptureBrowserEvent.js.map
DevTools failed to parse SourceMap: chrome-extension://gnldpbnocfnlkkicnaplmkaphfdnlplb/ContentScript/CustomisedWorkItemMessaging.js.map
DevTools failed to parse SourceMap: chrome-extension://gnldpbnocfnlkkicnaplmkaphfdnlplb/ContentScript/CaptureBrowserEvent.js.map
  • 1
    From the error messages in your post, your failing extensions are Microsoft Test & Feedback chrome.google.com/webstore/detail/test-feedback/… and LastPass: Free Password Manager chrome.google.com/webstore/detail/lastpass-free-password-ma/… :) You have to disable these in chrome://extensions to make the errors go away. You probably don't want to do this (i.e. if you still want to use them!). AFAICT it is a new bug in Chrome (see below).
    – MikeBeaton
    Commented Feb 17, 2020 at 16:24
  • I disabled my AdBlock chrome extension and the errors went away! Commented Apr 29, 2020 at 20:55
  • @MikeBeaton please show how you concluded that
    – barlop
    Commented May 28, 2020 at 20:57
  • @barlop See the section 'Fix?' in my full answer below
    – MikeBeaton
    Commented May 29, 2020 at 21:23
  • You might have ./path/file.JS.MAP missing. I just went to every ./path/file.JS and deleted last line starting with # which has instructions where the map ought to be. No map request = no warn messages.
    – s3c
    Commented Jun 22, 2020 at 11:11

6 Answers 6


For me it helped to only enable current context in devtools.

Selected context only checkbox enabled

Caveat: It is not sticky. You have to reset it every time you open DevTools.

Caveat: API calls to other domains won't show any errors as they belong to a different context.


I have filed a Chromium issue about this:


I think the multiple recent reports here look as if this is a new bug coming from an upgrade to Chrome.

It's also happening for me on a React/Webpack project which I'm working on which was building fine without this problem before.

I could not find any duplicate except for an old issue which I don't think is the same.


It's a bug! Partly in Chrome, partly in some of the extensions. It won't affect how the extensions work. The feature which is not working, loading source maps from extensions, should be irrelevant for end users of extensions and it was always not working, it's just that now DevTools is flagging the error.

NB If you are seeing this error for your own source map files when trying to debug under HTTPS... it's a different bug! Which is tracked but may take some time to fix.


If you're happy to lose the extension then as per other answers here, click on the links in the failed messages, then look just to the left of the address bar (not in the main window) to see which extension you need to disable.

enter image description here

If you need to keep the relevant extensions enabled, then either @Webber's answer using Selected context only works well (but it won't stay set when you close and re-open Chrome), or OP @Richard_G's suggestion of a filter looks good (and stays set) - but I found the suggested filter was cutting out too much stuff:

Try just -chrome-extension as a filter instead, as demoed in the images below.

enter image description here

enter image description here

enter image description here

  • 1
    It's a mixture of a real bug in Chrome DevTools (it can't load some source maps that it should be able to load, including those for extensions) and a real bug in some of the extensions too (some of them don't have source maps, but do have links referring to them). Which is showing up because DevTools now reports these problems, but didn't before
    – MikeBeaton
    Commented Feb 19, 2020 at 11:24
  • 1
    Latest fix is open and tracking here: bugs.chromium.org/p/chromium/issues/detail?id=974543
    – ENG_ACK
    Commented Jun 4, 2020 at 22:57

Same thing started happening with us since yesterday. I think this issue is related to an update pushed by Google on 7th Feb.


As per the answers / comments till date, it seems these 3 extensions are affected.

Adblock: cfhdojbkjhnklbpkdaibdccddilifddb
LastPass: hdokiejnpimakedhajhdlcegeplioahd
Test & Feedback: gnldpbnocfnlkkicnaplmkaphfdnlplb

For me, temporarily disabling these extensions worked, but a more permanent solution would be to raise a bug report.

It is also possible that this release made few extensions incompatible, so maybe we should wait for extension creators to release a compatible version.

Another temporary solution would be to allow extension to load "On click" or on "Specific Sites".

Like This

  • I did try your temporary solution without success. I use Adblock and LastPass, and need them, but I tried disabling them, again without success. Thanks for the suggestions.
    – Richard_G
    Commented Feb 11, 2020 at 18:08
  • Wappalyzer chrome.google.com/webstore/detail/wappalyzer/… also affected
    – MikeBeaton
    Commented Feb 17, 2020 at 16:26
  • The allow extension feels so close to a good solution. If you could blacklist extensions on certain websites (instead of "only run on website"), say blacklist localhost ;) then that would stop them from being loaded there. Commented May 22, 2020 at 12:33

Today it was happened to me too. It looks like some extension related chrome behavior is changed after chrome update.

A workaround to get rid of warnings is;

  1. Click the map file link
  2. Chrome shows which extension on the left of address bar
  3. Disable that extension

After disabling the extension, warning is gone.

  • Not sure if you noticed. None of these extensions are under my control. They are all JS, or perhaps jQ, provided extensions. And, as I mentioned, clicking on the link only gives me a "ERR_FILE_NOT_FOUND".
    – Richard_G
    Commented Feb 7, 2020 at 17:22
  • 2
    I tried that. In my case it says "Adblock Plus", but that is already turned off on localhost (where I just noticed the problem). However turning off this extension made the message go away. Is there something wrong with Adblock Plus?
    – Leo
    Commented Feb 7, 2020 at 22:24
  • Disabling the AdBlock extension completely worked for me, though not a satisfying solution.. Commented Feb 8, 2020 at 11:37
  • Removing AdBlock Plus did not change the situation for me.
    – Richard_G
    Commented Feb 8, 2020 at 15:04
  • yes I found that some extension cause problem for me
    – nima
    Commented Feb 17, 2020 at 12:01

I have a temporary bypass which is kind of ugly. Hopefully, the vendors will get this worked out among themselves. What I did was to add a negative filter to the console settings, as follows. I am not going to mark this as an accepted solution.

-DevTools failed to parse SourceMap: chrome-extension:

Within a screenshot: enter image description here

  • Hi! I found this filter cut out too much stuff? Have a glance at my answer here superuser.com/a/1526134/439040 where I've found out the origin of all this and also taken the liberty of suggesting an update to your suggestion here (I agree, using the filter does seems like a good plan for now!).
    – MikeBeaton
    Commented Feb 19, 2020 at 11:01
  • Wouldn't disagree at all.
    – Richard_G
    Commented Feb 19, 2020 at 18:31
  • 1
    From playing around a little I think the words with and without minus signs are working separately, word by word. So your current filter in this answer as it stands is saying "must not include the word DevTools, but must include all these other words", which would be why it is working (removing the unwanted messages), but also filtering out too much. If you're agreed, I suppose it could help others to update the answer here? Obviously it's your answer to your question, so up to you! :)
    – MikeBeaton
    Commented Feb 20, 2020 at 11:16
  • Interesting point. I am going to assume you are correct in your assessment. However, that leaves me with the question of what should be done. Hitting each word with a minus is probably going to filter far too many pertinent issues. Well, I knew it was ugly to begin with...
    – Richard_G
    Commented Mar 6, 2020 at 19:59
  • i think just using this : -gighmmpiobklfepjocnamgkkbiglidom should be enough. it only targets the adblock extension and allows all other things. offcourse you can add multiple strings to eliminate other extensions, but for me , only adblock was the problem.
    – vikrant
    Commented Apr 27, 2020 at 7:52

in my case it was Adblock Plus - free ad blocker 3.8 extension which you can get rid of message by disabling this extension

  • 3
    In all fairness, this remedy is worse than the disease: after all, it's a warning we're talking about, not a crash or an error, so disabling the functionality that you want is not a particularly good solution. Commented Mar 13, 2020 at 14:35
  • 1
    I'm not seeing the issue using "Adblock Plus" v3.8.4. Previously using "Adblock" v4.10.0. I disabled the latter. Commented Apr 21, 2020 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .