0

Not able to launch Ubuntu,

The Windows Subsystem for Linux optional component is not enabled. Please enable it and try again.
See https://aka.ms/wslinstall for details.
Press any key to continue...

Output of WSL status:

PS C:\WINDOWS\system32> Get-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux


FeatureName      : Microsoft-Windows-Subsystem-Linux
DisplayName      : Windows Subsystem for Linux (Beta)
Description      : Provides services and environments for running native user-mode Linux shells and tools on Windows.
RestartRequired  : Required
State            : Enabled
CustomProperties :

I have restarted many times and not able to launch Ubuntu1804.

Edit-1:

I have tried to launch .exe file using admin as well as the user privileges, through double-clicking the .exe file as well as from PowerShell itself.

5
  • 1
    Probably you are using old Windows 10 version. wSL feature is out of beta in several years ago. Clean install of latest Windows 10 OS may solve your issue. – Biswapriyo Feb 7 '20 at 5:14
  • 1
    @shaikmoeed - Why does it say Windows Subsystem for Linux (Beta), that isn't right, what version of Windows 10 are you running? You would have to be running 1703 which is 2 years old. – Ramhound Feb 7 '20 at 7:10
  • Try using lxrun instead. – Ramhound Feb 7 '20 at 8:15
  • @Ramhound Current version is 1607. Maybe I need to update it to the latest version 1909. – shaik moeed Feb 7 '20 at 8:39
  • @shaikmoeed - Windows 10 version 1607 has not been supported for nearly 2 years. You really should upgrade to the most recent version. Your issues are due to the fact, you have a version with only the beta version, which means your WSL Ubuntu instance will be 4 years old – Ramhound Feb 7 '20 at 8:54
1

I have tried to launch .exe file using admin as well as the user privileges, through double-clicking the .exe file as well as from PowerShell itself.

You are using Windows 10 Version 1607, which means you have to use lxrun.exe and bash.exe to manage your WSL instance. wsl.exe and wslconfig.exe are not applicable to Windows 10 version 1607.

Here are the steps you must follow to use WSL on Windows 10 version 1607.

The following instructions are for users running Windows 10 Anniversary Update or Windows 10 Creators Update:

  1. Enable Developer Mode
  2. Open PowerShell as Administrator and run: Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux
  3. Reboot
  4. Open a command prompt. Type bash and hit enter

The first time you run Bash on Ubuntu on Windows, you'll be prompted to accept Canonical's license. Once accepted, WSL will download and install the Ubuntu instance onto your machine, and a "Bash on Ubuntu on Windows" shortcut will be added to your start menu.

Sources:

4
  • Thanks for guiding me in the right direction. One small doubt, If I run any server(eg: Redis) from this bash, will it work the same as it is running on Linux machine or it works the same it works on a windows machine? – shaik moeed Feb 7 '20 at 9:07
  • @shaikmoeed - I am not sure I understand the question. Only WSL 2 runs the actual Linux kernel. – Ramhound Feb 7 '20 at 10:10
  • Okay, I need WSL 2 then. Thank you. – shaik moeed Feb 7 '20 at 10:26
  • @shaikmoeed - WSL 2 required Windows 10 version 2004 which isn't out yet – Ramhound Feb 7 '20 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.