2

I have an Asus 100TA laptop which came with Windows 8.1 pre-installed.

I decided to install Linux Mint on the laptop because the Windows was very buggy.

I installed Linux Mint 19.3 on the laptop.
Everything except for the webcam, Wi-Fi and speakers worked fine!
After some tinkering I managed to get the Wi-Fi and the speakers to work. But not the webcam!

The webcam is Aptina MT9M114.
I have tried to install the driver from here: https://github.com/jfwells/linux-asus-t100ta/tree/master/mt9m114-driver, but the webcam is still not working:

  1. I run make command and it was succesfull and I got a mt9m114.ko file.
  2. I run sudo make install and the mt9m114.ko file was installed in the kernel directory.
  3. I run sudo modprobe mt9m114 and the module was succesfully added to the kernel.

After adding the module to the kernel I excepted to have a device file in /dev called video0, but it has not been created!

When I run dmesg it shown me this.

...
[  400.052999] mc: Linux media interface: v0.10
[  400.071954] videodev: Linux video capture interface: v2.00
[  400.077423] mt9m114: loading out-of-tree module taints kernel.
[  400.299425] mt9m114 3-0048: chip found @ 0x90 (Synopsys DesignWare I2C adapter)

Please help me. I don't know what is the problem, and I want to make the camera working!

Thank you.

6
  • 1
    "With Windows 8.1 everything worked fine." and "because the Windows was very buggy"... well, which is it?
    – T.J.L.
    Commented Feb 7, 2020 at 13:09
  • I mean that all the hardware worked fine with Windows. Commented Feb 7, 2020 at 14:27
  • It might not necessarily be the mt9m114 depending on your exact model. Is it a t100, a t100TA, a T100TAM...? dmesg seems like its finding the USB controller instead. I never managed to make my T100TA webcam work with Ubuntu either.
    – Natsu Kage
    Commented Feb 7, 2020 at 14:44
  • Just want to say that these tablets work perfectly fine on Windows 10...
    – Natsu Kage
    Commented Feb 7, 2020 at 14:48
  • I have the Asus 100TA and I am sure in 100% that the camera is MT9M114, because it is responding to I2C commands (look in the last line in the dmesg output). Commented Feb 7, 2020 at 15:33

0

You must log in to answer this question.

Browse other questions tagged .