6

Upd-2 (2020-11-27): so far so good, everything flies fast. (win 10 pro 20H2 v10.0.19042) No major changes. Possible suspects:

  • I stopped synching photos from iPhone long time ago;
  • minimized number of folders which synch locally;
  • uninstalled adobe reader long time ago.

Update-1 (2020-08-30): the problem is no longer reproduced. Don't know what helped. Magic :) No major updates were made (same win 10 pro 10.0.18363 / v 1909).

== Will keep the original post for a while ==

Below I speak about locally cashed filed and folders. Windows 10 and OD are fresh to current date. I've reset OD (several times actually, reinstalled etc), and the problem persists for 1-2 years (thru many updates etc)...

As subject states, many operations are extremely slow on OD folders.

  • Most smaller folders open instantly, but some (normally bigger with images) open for 10+ sec.
  • Initially I've noticed the problem with images - opening a picture takes 10+ sec. I blamed XnView but it's not the problem.
  • OPENING MOST of the IMAGES from a OD folder (from Explorer etc) takes same 10+ sec.
  • Select All (Ctrl+A) on a folder with images takes MINUTES...
  • After selecting all images select any menu or right-click - 1 minute.

To reproduce:

  • Reset OD, (fast)
  • Sync only photos folders, (fast).
  • Open a folder - takes 1 min,
  • select all images (Ctrl+A) - 1 min,
  • Right click - 1 min...

Stopping sync on any step - doesn't help.

Copying folders outside OD root folder - helps immediately. Everything works immediately (momentary response), like it should be. As such, problem is somehow related to OneDrive.

Anybody experiences the same? Any ideas why?

PS. And I'm not talking about Word/Excel, which opens locally synced OD files slow (office Apps check the file online for recent updates, and it's OK).

Win 10 Pro, Version 10.0.18363 | v 1909.
Personal OneDrive, v 2019 build 19.222.1110.0006.
Files/Folders are already locally synched.
I use Explorer or TotalCommander.
Fast Internet (60 Mbit both ways - shouldn't be the problem).
SSD, 75 Gb free... modern PC (i5-5300U CPU @ 2.30GHz, 2295 Mhz, 2 Cores)...

Tx, Max

10 Answers 10

1

I had the same issue with a large OneDrive folder (several thousands of files) in a user (non-admin) account.

Finally found out that there seems to be a conflict between MacriumReflect (Free Edition) and OneDrive.

Uninstalling Macrium Reflect from an admin account fixed the problem.

The problem was simply reproducable by trying to open any folder inside the OneDrive folder (or the OneDrive folder itself) by double clicking it in Explorer or by trying to open the context menu. Both caused the Explorer to freeze for several tens of seconds. Uninstalling OneDrive (and rebooting) made the same folders responsive again. As mentioned by user1143638, navigating the folders worked without delays using the navigation bar left from the main windows.

After uninstalling Macrium Reflect and switching (log off/on) from the admin to the user account, the problem had disappeared completely.

I identified Macrium Reflect as the potential culprit by using Microsoft's (Process Monitor) (https://docs.microsoft.com/en-us/sysinternals/downloads/procmon), which always showed a remarkable amount of Macrium events when right clicking on the OneDrive folder.

The following changes (which I tried previously) all were without effect:

  • fully synching all files to the local computer
  • deleting whole OneDrive folder and resynching completely
  • Changes in the OneDrive folder properties ("Customize": change kind of folder to "general items")
  • Changes in OneDrive folder options
    • "General" => "Show ... in Quick access"
    • "General" => "Clear File Explorer history"
    • "View" => "Always show icons"
    • "Search" => "How to search" and "When searching non-indexed locations"
  • Windows Search
    • Excluding OneDrive folder from Windows Search
    • Disabling Windows Search

Environment:

  • Windows 10 Pro 64bit Version 20H2 Build 19042.630
  • OneDrive Client Version 2020 (Build 20.169.0823.0008)
  • Macrium Free Edition - sorry, don't recall the version number after unsinstalling... ;-)
1

Thanks to the poster above speaking about Process Monitor I was able to track down the root cause of my problem.

Short Answer, Spybot Search and Destroy 2.7

Longer Answer:

The problem is not really the software but what the software does to protect you.

There is a feature called "Immunization" this feature adds 1000's of deliberately restricted domain names to the security settings of internet explorer.

Well go figure, Excel and likely a lot of Microsoft products depend on those Internet Explorer security settings (especially when accessing network resources or shared resources like OneDrive).

It may also be possible that you have another type of internet security software that has added similar domain settings.

I caution anyone who uses Windows Registry editor however you can view entries here:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains]

Note that each entry has a different value based on its restriction level.

If the entries were added by Spybot you can actually de-immunize.

You can also remove the entries manually from internet explorer but that will take forever.

Time before fixing these entries to open an excel file: 54 seconds.

Time after removing these entries to open an excel file: 3 seconds.

Hope this helps others who have been struggling with this for months too.

1

This is probably a very special case but it still could help someone:

For me it was OldNewExplorer which kept the Microsoft Search indexer failing.

Some weeks ago I already noted problems with accessing the OneDrive folders. But I did not find a solution. Today again. It got worse and worse and it seemed to effect other folders like "Downloads". Even the feedback hub app did not start (It did not become responsive and I stopped it after some minutes).

I finally found in the Events Viewer (under System) that "The Microsoft Search service terminated unexpectedly." Hundreds of times. In the Application log I found entries like: "Faulting application name: SearchIndexer.exe" and "Faulting module name: OldNewExplorer64.dll".

From older logs (a month ago) I saw that this failed every two minutes but today every 1-2 seconds.

I had installed OldNewExplorer years ago so I did not remember it.

1

I had similar issue when each Microsoft OneDrive (Business) folder will take 30-60 seconds to open, and files were taking too long for patience. I tried diverse options, none worked.

Then I stumbled upon the Microsoft Support and recovery assistant. I ran that against OneDrive (there is an option to choose the app for which it must investigate) and it identified few files with irregular names. Seriously did not know where they were however could assume that it was some temp file created during an error sync.

It corrected the file names and once I did that.

I tried opening the folders and it was normal.

This could be one of the methods you can try as well.

0

I ran into the same issue and had tried resetting OneDrive with some limited success (Some sync'd locations worked OK, but others still had the delay).

Using Process Monitor, I was able to find that there was a problem with unlocking a file. The file was located in C:\Users\USER\AppData\Local\Microsoft\Office\16.0\OfficeFileCache and since it was a cache, I took a risk and emptied it after exiting all my office apps.

Following this, files started opening quickly.

Try this at your own risk as I plan to live with any consequences, but I'm happy to have quickly opening files once again!

0

Just for completeness. I had the same problem and it happened to be iCloud Drive: I disabled the sync for Photos (actually didn't need it), and immediately the File Explorer began to respond again fluently.

0

I had the same issue, and it was iCloud causing the issue, once its removed, all works fine like a charm!

0

Ran into the same issue. Tried everything: reinstalling OneDrive, switching between files-on-demand mode and full sync mode, disabling AV etc.As it turned out, the OneDrive folder was left after the previous Windows install, and didn't have the correct system owner ID assigned (the owner was listed as something like S-1-12-1-1234564589-1234564798-1234564798-1234567891).

This was resolved after assigning the correct user name by running the command below (admin privileges required):

takeown /s YOURPCNAME /u AzureAD\YourUserName /f "D:\OneDrive - Company Name" /r /d Y

If the above doesn't work, try this command (admin privileges required):

icacls "D:\OneDrive - Company Name" /q /t /grant "AzureAD\YourUserName:(OI)(CI)F"

Don't forget to insert your data before running the commands above and make sure you check the links below so you understand all the options used!

https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/takeown

https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/icacls

0

I had a similar problem. My folders in OneDrive and iCloud Drive opened very slowly. I tried to reinstall both OneDrive and iCloud Drive, nothing helped. But I found the reason, the most important thing is that you need to install the iCloud drive not from the Microsoft store, but you need to download it from a source on the Internet and install it. This problem immediately disappeared for me.

-2

I have the same issue. I don't know a solution, but for me it does work correctly if you use the navigation bar on the left side. So main tiles in the main screen are slow, but selecting it from the left side works fine.

this helps at least to the point where you have to open the file from the main screen.

Update: I just uninstalled it and reinstalled it, using the internal onedrive instal file, located in: C:\Windows\WinSxS. Worked for me. so if you reinstalled, using the online install file, maybe you can give this a try as well.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .