1

Under Printers and Scanners, I see the following devices:

  • Fax
  • HP PSC 750
  • Microsoft Print to PDF
  • Microsoft XPX Document Writer
  • OneNote

No matter which one I click on, I am presented with the same two buttons: Open queue and Manage. No matter which button I press, nothing happens. If I double-click the device itself, nothing happens.

On the other hand, under Bluetooth & other devices, there is a Devices and printers which mysteriously can't be found if I type in either printers or devices. If I click on that, I get a Devices and Printers panel showing the same devices as above. I can actually double-click HP PSC 750 and scan something.

Why are there two different panels showing the same devices?

In Windows 10, is one more authoritative than the other?

Is the Printers and Scanners window supposed to be unresponsive?

BACKGROUND

I am on Windows 10 Pro 64-bit. In case the following might be relevant, I spent the last week trying to get the HP PSC 750 recognized on this new Windows 10 laptop. I went to their Universal Print Driver for Windows and installed the USB Driver, which enabled printing but not scanning. Finally, I enabled Receive updates for other Microsoft products... under Advanced options for Windows updates and initiated an update. That enabled printing and scanning after unplugging and replugging the USB cable. I'm not sure if any of these steps might have caused the Printers and Scanners panel to be unresponsive.

  • 1
    @vssher: Thanks! Accessing Printers and scanners as Administrator did the trick. Each device has options Open queue, Manage, and Remove. Remove was not available when accessing Printers and scanners as non-Administrator. I didn't try Remove, but both Open queue and Manage were responsive. Neither are for actually using the device, e.g., to initiate a scan. – user2153235 Feb 8 at 16:43
  • @vssher: I also tried gpedit.msc as Administrator, but I don't see the hierarchical path that you provided. I found Accounts: Administrator account status under Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options. After reading about it online, and considering my last comment above, I decided not to mess with it. – user2153235 Feb 8 at 16:43
  • 1
    @vssher: Your second solution also worked: Under Printers and scanners, select the printer, then tab to the Open queue or Manage buttons and press Return. Would you be so kind as to post your two "solution" as an answer? – user2153235 Feb 8 at 16:51
  • If you can post your two solutions, I can mark it as the answer. If you don't feel it worth the time, I'll post it. Thanks. – user2153235 Feb 9 at 2:00
  • Thank's for the update, I have posted all my comments into an Answer box. – vssher Feb 9 at 2:07
1

On this computer, Windows 10 Professional, I have Local Computer Policy and also
Group Policy Editor.

If you switch to log on using administrator account is the option working? Open Local Secrutiy Policy > Local Policies > Security Options > Accounts:

Administrator account status + Enable +Disable.

A lot of people are having this same issue, even with the lastest Windows release. There is however a proposed workaround from Bibs Rielley Wednesday, September 18, 2019 [1].

| improve this answer | |
  • 1
    Thanks, vssher. I found that Bibs Rielley's suggestion to tab to the Open queue and Manage buttons to be most convenient. Neither of them seem present the same functional options as accessing a device from the Devices and scanners panel, e.g. in the case of a PSC 750, to scan. – user2153235 Feb 9 at 2:52
  • 2020-04-27: I tried for an hour to search for Devices and scanners without luck. I was finally able to find myself to a familiar looking panel using this recipe. Not sure if Devices and scanners was a typo or whether the name of the panel changed. – user2153235 Apr 27 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.