0

I've recently changed up networking at my house and added a new router and IP scheme. With it, I changed the IP address asociated with an ssh server I have on the LAN. Whenever I try to connect to the same server with the different IP address from Windows, I get a "Permission Denied" error. Not (pubkey) error, just a Permission denied.

enter image description here

It is a Windows specific problem as I'm able to spin up a VM on the same machine with a bridged adapter, get an IP address in the same range, and connect to the SSH server without any issue.

Is there a place that Windows keeps ssh server keys and checks them system wide for IP changes? I've had a similar issue with Debian but it was a quick fix by opening up the known_host file and clearing it out.

I don't think it's the firewall as I don't see any rules blocking this type of traffic and the general "Firewall Profile" is set to a private network. As far as permissions go, I tried WSL with sudo and command prompt with admin privilages but got the same exact permission denied prompt.

Anyone else experienced this issue or might have some other troubleshooting steps to try out?

0

Oh wow, this was interesting. Ran the network troubleshooter and tried accessing an http server I've been having troubles with as well. It pointed me to a security setting that had been set by an app.

Looks like the "Invisibility on LAN" option that NordVPN provides actually blocks requests on the local subnet. Even when the app isn't running or connected to a VPN. Good to know but oh so anoying to find out quite some troubleshooting later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.