0

The title says it all. I just installed CentOS 8 on my laptop and the touchpad isn't working. Like many, I hate the touchpad but for times like when I'm on an airplane there often isn't room for a mouse.

Speaking of a mouse, my USB mouse works just fine... just don't have the same luck with the touchpad. I tried running

synclient -l

and got

command not found...

So I ran

yum search synaptics

and got

No matches found.

So I ran

less /proc/bus/input/devices | grep -i touch

N: Name="ELAN1300:00 04F3:3057 Touchpad"

A ha! Perhaps we are on to something here.

So I ran the following five commands and didn't get any output:

lspci | grep -i elan
lspci | grep -i touch
lsusb | grep -i elan
lsusb | grep -i touch
lsmod | grep -i elan

Are there any other commands I should run which would shed some light on what is going on?

When I Google "elan touchpad linux driver" I cannot find squat. Is there a fix and/or a driver/package/etc., out there for this device?

0

let's start with something easy, first, try to find what provides 'synclient' with:

dnf whatprovides synclient

as this will allow you to install what possibly may be needed, like the following:

xorg-x11-drv-synaptics-1.9.0-2.el7.x86_64 : Xorg X11 Synaptics touchpad input
                                          : driver
Repo         : base
Corrispondenza found in:
File name   : /usr/bin/synclient

Next, you need to check what is your Xorg environment is telling you and there may be some issues.

Try to find out the log file, possibly in '/var/log/' as this will tell you if there are errors by looking form '(EE)' within the file 'Xorg.0.log'.

For hardware issues, I suggest you 'lshw' command or 'lspci'/'lsusb'.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.