Using Windows 10 to 10 RDP over Open VPN and Wifi, there are sporadic connection issues - I assume. The problem I describe happens more often when the Wifi connection is bad, but also happens on a very good (as far as I can tell) Wifi connection.

Sporadically, the remote screen stops updating. I just see whatever I saw last. Keyboard/mound inputs still seems to work, which I notice after reconnecting. There is no RDP reconnect screen, the tool seems to think the connection is still working.

There is no auto-connect or any sort of fix on the RDP connection, I have to maually disconnect and reconnect.

In OpenVPN log, I see sporadic errors, nowhere near as often as I have the RDP connection issue, so I would assume that it is unrelated, especially since RDP should recognize a broken connection.

In a bad scenario, this happens every few minutes and really disturbs the workflow.

Is there some setting that can fix this and/or automatically reconnect the RDP (noticing that the connection is broken)?

  • It's impossible to help without the OpenVPN server and client configs, as well as the logs from each showing the RDP traffic. Server config should be set to verbosity 4 and client to verbosity 5. Please anonymize any private info, such as WAN IP, DDNS, OpenVPN port #.
    – JW0914
    Feb 10, 2020 at 12:45
  • Thank you, did not think that was necessary, since the connection is "obviously" broken. That will take a while to (find the time to) collect. Feb 10, 2020 at 12:57
  • You can't diagnose a VPN issue without the relevant configs and logs
    – JW0914
    Feb 10, 2020 at 13:22
  • RDP tries to use by default UDP as transport protocol. In your case it seems like something is blocking the UDP packets to your computer (could also be something like UDP packet size). If you are not able to identify and solve the network problem you can force RDP to use TCP via local group policy.
    – Robert
    Aug 11, 2020 at 9:03

4 Answers 4


Ran into this issue as well using RDP to a remote site over OpenVPN. Wasn't on every computer at the remote location, but affected maybe 2-3 of the computers on the LAN (although the issue never happened when I would RDP to a known working connection within that LAN and RDP from that working machine to the ones that were giving me issues over VPN)...Also, SSH tunnelled VNC connections worked fine on ALL the computers over the VPN tunnel. Received constant ping response from these problem machines and the network speed on iPerf between my device and the problem machines over OpenVPN were all running as expected. Clearly was not a network or VPN issue...

Since it was not a network issue, started looking at it as possibly an application layer issue. Lowering the performance settings (in the Display, Local Resources, and Experience tabs) in the Windows native Remote Desktop Connection client application didn't do anything for the problem RDP connections. Did some research on it looks like someone was able to solve it on the OpenVPN forums by updating the OpenVPN connect client to the latest version, but that didn't work for me.

Discovered that the same issue was happening on both my desktop and laptop (both running Windows 10 2004) when connecting to those same computers, but when I used RDP on iOS using Microsoft's Remote Desktop client, there were no issues...

So, I went to the Microsoft Store app in Windows and installed that version Microsoft Remote Desktop app, and voilà! the connections worked normally.

Why this is... I don't know... one of the machines giving me the biggest issue was running Server 2012 R2 so I know it wasn't because my client was outdated. All the other computers in the office were running recent versions Windows 10, but only 2 of those devices out of 9 were giving me the original issue and one of them would work OK some time... but using the store app RDP client works perfectly on all the problem computers.

  • Thank you. I actually 1) have the same issue in local network (without OpenVPN) though a lot less often and got an improvement by lowering the quality settings and 2) have tried the same with another RDP app, which had a stable connection, unfortunately did not have multi monitor support though. Will try the one from the (windows) app store. The one that got 3/5 stars?! Aug 11, 2020 at 14:07
  • Sadly, the app you reference to seems to be ancient (or maybe the Microsoft Store which I never use just doesn't list updates), also it has no multi monitor support and hence sadly is not usable for me. I use RDP not just for maintenance or the like, but for "real" work, just remote, so the second monitor is a must. Aug 11, 2020 at 17:58

All credit goes to Erik9261 from https://community.spiceworks.com/topic/2269433-remote-desktop-randomly-freezes-up , you have to scroll down for his answer. You can achieve this via registry (e. g. via cmd, see below) or gpo too.


I've had several clients reporting the same thing. Turns out, it looks like Microsoft made some changes to RDP in Windows 10 version 1903, to make it use UDP rather than TCP. There was a registry setting that you can add which forces it back to the old TCP connection. Since changing this, the clients haven't had any freezes happen.

I think you only need to add this key on the connecting client PC, but in my case I added it on the client and remote PC both, just in case.

Fire this off in an Admin CMD, then restart any active RDP sessions. Batchfile

reg add "HKLM\Software\Policies\Microsoft\Windows NT\Terminal Services\Client" /v fClientDisableUDP /d 1 /t REG_DWORD

It was soo annoying - if you are affected, restarting RDP in the middle of the work, multiple times, input still goes through, so in the worst case one clicks on a very bad button. Alternative (good) RDP solutions like the ones from the Windows Store or mRemoteNG are not having multi monitor support (yes, it is 2020, everyone should have multiple monitors, and RDP is not only used for support but also for full remote work..). I had this issue a lot over OpenVPN, and a lot more when connected via (full signal strength) WiFi. Sometimes even through local LAN, though there is a big difference between the Ethernet card provided (Notebook built in=bad, docking station=good).


Can add that we have had the same issue, and now with the Windows 10 20H2 update (on both machines) it seems to have been resolved


There are 2 solutions to this issue.

The first is given by @andreas-reiff in his answer referencing: Remote Desktop Randomly Freezes up - see Erik 9261

The second method uses the Windows GUI rather than the command line to edit the registry and is referenced here: RDP Connection Freezes in Windows 10

Method 2 Steps:

  1. In Windows search box, type: gpedit
  2. Click Edit group policy [Control Panel] application.
  3. Click Computer Configuration
  4. Click Administrative Templates
  5. Click Windows Components
  6. Click Remote Desktop Services
  7. Click Remote Desktop Connection Client
  8. Double-click Turn Off UDP On Client
  9. Select Enabled
  10. Click Apply and then OK
  11. Restart your Remote Desktop Connection

Another detailed discussion of this issue can be found here: Remote Desktop intermittently freezing. See the answer provided by @Nat.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .