7

I've configured an external handler for telnet:// links following these instructions. It works great, but every time I click on a click chrome asks me:

Open xdg-open? http://<site i am browsing> wants to open this application

I would like telnet links to Just Work without the intervening prompt. How do I tell chrome to launch the external handler without prompting?

[NB: I'm running Chrome on Linux]

5
  • See if this helps>>>>support.google.com/chrome/a/thread/3859524?hl=en
    – Moab
    Feb 10, 2020 at 15:26
  • 2
    @Moab Thanks for the pointer! Adding URLWhitelist: ["telnet://*"] to the policy makes things work as I want, although it's odd that's at the policy level and not the user level.
    – larsks
    Feb 10, 2020 at 16:49
  • glad you resolved it.
    – Moab
    Feb 10, 2020 at 18:05
  • It's very odd to be at the policy level, since it's something I can configure for my company, that will actually be effective on my client's computer (when I'm using their hardware)!
    – Auspex
    Mar 10, 2020 at 10:44
  • 1
    You can also enable the "Always open these types of links in the associated app" checkbox, and then check it once: superuser.com/questions/1481851/…
    – EM0
    May 18, 2020 at 16:27

1 Answer 1

0

Solution in comment worked for me aswell. I'll post it.


Create following path and file:

sudo mkdir -p /etc/opt/chrome/policies/managed/
sudo touch /etc/opt/chrome/policies/managed/managed_policies.json

Open permissions for this file:

sudo chmod -R 775 /etc/opt/chrome/policies/managed

By default adding following content to this file should add the checkbox to remember your choice:

{
    "ExternalProtocolDialogShowAlwaysOpenCheckbox": true
}

This worked for all external website for me. For custom link (like telnet://* in the question), you may need to add those links to the whitelist:

{
    "ExternalProtocolDialogShowAlwaysOpenCheckbox": true,
    "URLWhitelist": [
        "telnet://*"
    ]
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .