My keyboard is interpreting input incorrectly. I believe I am a victim of toddler keyboard mashing. Unsure of what was changed, and never experienced this before.

I am running Win 10 Pro version 1909 build 18363.592. The keyboard I have is is a Topre Realforce R2TLSA-JP3-BK/AHAZ07. The keyboard layout (Japanese 106/109 key) is recognized correctly as verified by testing each key, and I am using an IME keyboard.

However, there are some particular issues that I cannot find settings to rectify:

  1. Pressing CAPSLOCK does nothing. (I expect it to turn off CAPSLOCK as per the IME keyboard preferences, which I checked)
  2. Pressing GRAVE key changes my input (as expected) which I mention because LEFT-CTRL and WINDOWS key are also changing my input which is NOT expected. LEFT-CTRL will not currently function as CTRL. (RIGHT-CTRL is fine)
  3. Through trial an error I have found that disabling CAPSLOCK can be done by holding LEFT-SHIFT and pressing LEFT-CTRL, but only in that order.
  4. Not an issue, but all the keys on the right side of my keyboard appear to be working correctly.

It is also worth nothing that in my "Text Services and Input Languages" settings, the "Turn off CAPSLOCK key" setting is set to "Press the CAPSLOCK key" and "Hot keys for input languages" has only two options right now. They are "Between input languages" which is set to "(NONE)" and "To Japanese (Japan) - Microsoft IME" which is also set to "(NONE)". So theoretically, nothing at all should even be changing my input modes as mentioned in bullet (2) above.

Edit: Found keyboardtester.co and it is showing me a few things.

  1. My LEFT-CTRL key is not even registering as a keypress. Neither does the GRAVE key. Both are changing my input mode via the IME.
  2. SHIFT is recognized as expected.
  3. CAPSLOCK is registering as LEFT-CTRL.
  4. Holding LEFT-SHIFT and pressing LEFT-CTRL is registering as CAPSLOCK.

Wires are crossed somewhere...

1 Answer 1


I fixed it, but unfortunately dont know what the cause was and the "fix" was more akin to resetting to defaults. For all I know, some alternate keyboard mode was engaged somehow because after fixing things my CAPSLOCK engaged light on the keyboard is back to red. I didn't notice, but before it was green.

What I did could have backfired, so if anyone runs into this in the future and tries these steps, take care to do so thoughtfully.

  1. In Win10, "Preferred Languages" contains keyboard layout and IME settings. I rotated these out. When the problem occurred (i.e. my starting state) I had both English and Japanese, with English as primary. So I deleted Japanese (non-primary) and re-added it fresh. Then I made Japanese my primary, and deleted English, then added English back. Finally, I deleted Japanese altogether so all I had was English. This made the input mode switching stop when pressing LEFT-CTRL and GRAVE.
  2. Next, I went into my device manager and found two HID Keyboard entries there. This is a 2-day-old Windows installation and I have never used another keyboard, so I found this odd. Even after the fix I see two HID Keyboard entries. While strange, perhaps the issue has something to do with my keyboard moreso than with Windows. This second keyboard entry in Device Manager is what leads me to believe that my system may have somehow entered into an alternate keyboard mode. With the keyboard still plugged in, I removed both HID Keyboard entries in Device Manager. Then I unplugged the keyboard and plugged it back in a few moments later and the HID keyboard entries came back.

After this all my keys were working as they were before the issue occurred, but without any IME or other configurations since I removed them. I had to go back in to "Preferred Languages" and reconfigure the keyboard layouts, IME settings, download language packs, etc. But afterward, it is back to normal working order.

Side note: I have my keyboard wrapped in a silicon cover so this is not a case of foreign substances getting into the keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.