0

I have a CSV file with some CSV value in a cell as below.

2048,4,0,0,4,"1334,1335,1338,1339"

When I open it with Excel, it shows enter image description here.

How can I let the Excel display the number as 1334,1335,1338,1339?

0

In general, you are always better off Importing CSV files and not Opening them.

You will then have the opportunity to designate that column as TEXT.

If you do that, the data will import and display as you specify.

  • Just to make the solution more details. Import the data by clicking "From Text/CSV" under "Data" tab. Click "Transform Data", right click on the column header, "Change Type" to "Text". – SamTew Feb 12 at 1:38
  • @SamTew I did not include it because, although CSV Importation has been around since at least Excel 2003, and possibly earlier, the exact methodology of where to access that feature is version dependent. Your method would only work in Excel 2010+ with Power Query installed (which was an option in 2010-2013. Earlier versions had different ways of getting to a text-import-wizard. – Ron Rosenfeld Feb 12 at 1:47
0

Check if your Excel has comma as "thousands separator" and period (.) as decimal point. It is in the "Advanced" part of Settings for Excel. If so, one solution might be to change this, another might be to create the CSV file using semicolon as separator (not comma).

  • I have tried to untick the "Use system separator" which includes decimal and thousands separator but the problem still exists. – SamTew Feb 11 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.