1

im trying to set up a virtual machine of dos using oracle on windows 10. using all default settings (32mb of ram, virtual hard disk with 500mb, hard disk file type = vdi... )

specific version of virtual box { VirtualBox Graphical User Interface Version 6.1.2 r135662 (Qt5.6.2) also i should mention dos 6.22 }

i receive this error. how can i fix this. i just want to run a vm of dos

Not in a hypervisor partition (HVP=0) (VERR_NEM_NOT_AVAILABLE).

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

the common solution to this error is to go into settings and turn all acceleration options off, however i cannot accept the new settings.

in the options settings i get an error telling me to turn this off. i cannot accept settings until error resolved, but doing what it says does not resolve the problem

evidence provided below

edit) all previous images reformed into a neater image enter image description here

  • Try using 16 Mb of memory as there is a limit to what DOS can address. Otherwise as suggested above, turn VT-x ON and make sure Virtualization is enabled in BIOS – John Feb 11 at 20:08
  • in the options settings i get an error telling me to turn this off. i cannot accept settings until error resolved, but doing what it says does not resolve the problem – tgmjack Feb 11 at 20:09
  • the 16 mb thing didnt work i got the same error :( – tgmjack Feb 11 at 20:11
  • and no amount of messing with the settings for acceleration allows me to click accept. this is demonstrated in the image – tgmjack Feb 11 at 20:14
  • 2
    Did you activate VT-x in the BIOS...? You've never mentioned accessing the BIOS to confirm it's activated. It often is disabled at factory settings. – Natsu Kage Feb 12 at 0:01
0

In VBox configuration settings you can set the checkbox to use VT-x. But the enable / disable VT-x can be set as the BIOS UEFI feature. This is the motherboard (chipset) settings, but it also depends on CPU used. All modern (at least 7years old) AMD CPU has this feature. The Intel CPU you must test. In Linux you can simply type

lscpu |egrep --colour vmx

in console and if your CPU does not have this feature, you get no output. If you want to use the VT-x in VBox, you have to enable the VT-x in BIOS. The VBox can run the virtual machine without the HW support, but in this case you VM may run less secure, reliable, performance.

| improve this answer | |
  • Author is using a Windows host. – Ramhound Feb 11 at 20:48
  • changing chipset settings also does not resolve the problem and allow me to click ok. new image with more evidence added – tgmjack Feb 11 at 20:52
  • @Ramhound - I had guessed the MS-Windows host, thats why I explicitly wrote In Linux . I admit I do not know how to investigate this in MS-Windows, but there is plenty of Live Linux OS bootable CD / DVD / USB so that if there is no other way Linux can be easy used. You are welcome. P.S. It should be a good practise to identify the OS with its full name MS-Windows not to confuse with an elder X Windows – schweik Feb 12 at 7:20
  • @schweik - The author specifically indicates they are using Windows 10 – Ramhound Feb 12 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.