I have 1.5 GB of RAM installed on an older Dell, Pentium 4. I just installed Ubuntu 9.1 and the system is only seeing 244 MB of RAM, even though there is 1.5 GB on the system. The BIOS sees all of it. I ran a Knoppix disc and it only saw 25 MB upon booting.

I made no particular changes to the installation taht would affect this. I looked through the BIOS and the only setting I could see was the AGP aperture. Not even sure what this is.

Anyone know where I went wrong?

I also tried moving the memory modules around on the board. Booted with the 1 GB stick, still saw 244 MB.

NOTE - This same system, except for the hard drive, had Windows XP running on it. The user who ran it said that the RAM was good and always showed 1.5 GB.

Here is sudo cat /proc/meminfo

MemTotal: 250064 kB
MemFree: 3832 kB
Buffers: 13356 kB
Cached: 52216 kB
SwapCached: 19676 kB
Active: 91504 kB
Inactive: 113884 kB
Active(anon): 60572 kB
Inactive(anon): 82156 kB
Active(file): 30932 kB
Inactive(file): 31728 kB
Unevictable: 0 kB
Mlocked: 0 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 250064 kB
LowFree: 3832 kB
SwapTotal: 4883720 kB
SwapFree: 4781204 kB
Dirty: 496 kB
Writeback: 720 kB
AnonPages: 123796 kB
Mapped: 23368 kB
Slab: 17248 kB
SReclaimable: 7932 kB
SUnreclaim: 9316 kB
PageTables: 5304 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 5008752 kB
Committed_AS: 740372 kB
VmallocTotal: 770600 kB
VmallocUsed: 26008 kB
VmallocChunk: 662544 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 4096 kB
DirectMap4k: 114128 kB
DirectMap4M: 147456 kB

Hardware configuration:

  • eMachine T3958
  • Intel Celeron D 340, 3 GHz processor, Socket 478
  • 1.5 GB RAM (one 1 GB and two 256 MB sticks)

I posted dmesg and hwinfo --short on pastebin.

EDIT - I found out some additional, rather important information just now. My monitor configuration was such that, when I changed my monitor to the second channel of a 1>2 VGA splitter, I see additional information upon booting:

Alert! OS install mode enabled.
Amount of available memory limited to 256MB.

I'm not sure what this means or from where it originated. Do I have a BIOS problem?

EDIT - So upon searching through the web and my BIOS, I found a setting in the BIOS called "Install Mode." This was turned "on" for some reason. Not sure if I did it or it changed as default when I installed the new hard disk. Anyway, this was my problem the whole time. Errgh. Thanks for everyone's help!

  • Where do you see this? – Ignacio Vazquez-Abrams Jun 15 '10 at 0:31
  • In system monitor under system and the fact that my system runs slow... – nicorellius Jun 15 '10 at 0:32
  • can you run this command and paste the output? cat /proc/meminfo – James T Jun 15 '10 at 0:38
  • yah, already ran it... right at the top it reads MemtTotal 250064 kb. I'm on another system right now, and that system is updating... I will paste later. – nicorellius Jun 15 '10 at 0:43
  • That is very strange indeed. Have you tried running memtest from knoppix? Type "memtest" at the boot prompt instead of pressing enter to boot into the gui. – James T Jun 15 '10 at 0:47

The BIOS RAM map is only telling Linux that there's only 256MB of memory available:

BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)    : 640k
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000ff74000 (usable)    : 260560k
BIOS-e820: 000000000ff74000 - 000000000ff76000 (ACPI NVS)
BIOS-e820: 000000000ff76000 - 000000000ff97000 (ACPI data)
BIOS-e820: 000000000ff97000 - 0000000010000000 (reserved)
BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
BIOS-e820: 00000000fecf0000 - 00000000fecf1000 (reserved)
BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)

Ideally, fix your BIOS. Or, try booting with mem=1536m specified as an additional kernel parameter. You may need to tweak it slightly - Linux will crash and burn if you specify more memory than available.

  • Why would the BIOS map tell me this, even though when I launch the BIOS with F2 on start-up, and scroll to memory, it shows all of it: 1536 MB ? I will look into the kernel tweak... How would I "fix" the BIOS? Would this require updating the firmware (flashing it)? Thanks. – nicorellius Jun 15 '10 at 18:05
  • 1
    I also found this quote from faqs.org/docs/Linux-HOWTO/BootPrompt-HOWTO.html#ss2.4 "In some cases, the memory reported via e820 can also be wrong, and so the mem=exactmap was added." It looks like I can use mem=1500m and see what happens. Literature says if I specify more memory than I have, bad things will happen. What kind of things? Can I reboot without the mem= parameter and get back to where I was? – nicorellius Jun 15 '10 at 18:20
  • The mem=???? parameter is one time only if you add it at the boot prompt. To make it permanent, add it to grub.conf or lilo.conf – MikeyB Jun 15 '10 at 21:39
  • Yes, got this eventually. Thanks. Did you see the other part of the question? The last EDIT? It seems something is preventing my system from using more than 256MB RAM. – nicorellius Jun 15 '10 at 22:20

Install Mode was set to "on" in the BIOS. Either I changed it inadvertently or it defaulted when I installed a new hard disk. Changed this back and it is seeing all the RAM.

  • 1
    Ah... this would fall into the category of 'Fix your BIOS' :) – MikeyB Jun 17 '10 at 17:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.