0

After a recent Windows update, I stopped being able to control the volume of my external bluetooth speakers (Anki SoundCore 2) through the Windows volume slider. When I pair it via bluetooth to my laptop (Inspiron 7577), two devices appear on the volume control:

  1. SoundCore 2 Stereo
  2. SoundCore 2 Hands-Free AG Audio

On the first one the sound is good but I cannot control the volume via Windows. Only by manually going to the speaker itself and pushing the physical buttons. Then the volume changes and the Windows slider with it.

On the second one I can control the volume but the sound is not good.

I've tried:

  1. Re/Unpairing, removing and rebooting both PC and speakers.
  2. Sigverif Run Command.
  3. Running DISM.exe /Online /Cleanup-image /Restorehealth
  4. Running sfc /scannow in Windows powershell with admin rights (no issues were found).
  5. Removing only the headset.
  6. Unchecking the checkbox of in 'Hands-free telephony' in Hardware Services (in Devices and Printers).
  7. Updating Blutooth drivers.
  8. Windows troubleshooting Bluetooth and Sound devices.
  9. Checking for issues in Device Manager
  10. Disabling, enabling, disconnecting combinations of the two in Control Panel, Sound.
  11. Connecting through AUX cable but I get an annoying background noise, and windows doesn't even recognize the speakers. This is the 2nd AUX cable I get, so it shouldn't be the cable's fault. The sound just stops going through the laptop speakers and goes to the external speakers instead. Windows still thinks I only have the laptop speakers. I can control the volume through windows though.
  12. Going to services.msc and restarting Windows Audio.
  13. Pairing the speakers on someone else's laptop (Latitude 5580). There it works perfect (i can control the volume both for stereo and hands free through windows) so it's not the speaker's problem. I also notice that on this laptop I get a popup asking which type of device (speaker/headset/headphone) I just plugged in in the AUX connection, whereas in mine it doesn't with any kind of device that I connect there. I have the popup enabled in MAXXAudioPro. There it also doesn't recognize that I plugged in something else.
  14. Uninstalled smartbyte;
  15. Disabled MaxxAudio Pro.
  16. Installing latest version of Realtek Driver's from Dell's website.
  17. Installing latest version of Realtek Driver's from Realtek's Website (Realtek HD Audio Manager R.282).
  18. Using HD Audio Device (Windows Audio driver instead of Realtek's).

I have the exact same issue with another bluetooth headset (earphones + microphone). But before the update somehow it worked fine on these speakers.

Not sure what else to try, or what could be the problem. Ideas very welcome...

SoundCore 2 Hardware Properties (in Devices and Printers)

Bluetooth icon for the speakers shows up as headset

SOLUTION: You have to turn off the “absolute volume” in the registry: https://support.microsoft.com/en-us/help/14169/windows-10-fix-bluetooth-problems 178 It’s the registry part in the last section " Troubleshoot problems with Bluetooth accessories" in “Audio”.

You can also change the value of “DisableAbsoluteVolume” manually into 1. (Path: HKLM\SYSTEM\ControlSet001\Control\Bluetooth\Audio\AVRCP\CT)

  • Hello there. Why do you not simply uninstall the Windows Update? Updates can be uninstalled because exactly this: they like to break stuff, haha...*sigh* – Natsu Kage Feb 13 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.