0

I read the Microsoft documentation and this is supposed to be the command:

set-mailboxfolderpermission [email protected]:\calendar -user [email protected] -accessrights editor -sharingpermissionflags none

userA is admin, PowerShell is logged into exchange admin with userA's account. userA's calendar permissions are: userA-owner; userB-editor-delegate.

I get no error and the get command still shows the delegate flag. I've also removed the user and re-added but the flag is still there.

I am the exchange administrator using an "admin" account (according to goDaddy). The host is not Microsoft but GoDaddy's o365 abomination.

Am I doing something wrong?

2
  • Since the commentary has gotten to a point where it isn't useful anymore, which I am to blame for, I have simply deleted my commentary. You can disregard my original comment. However, in the future I hope you use the tools to reopen questions, instead of submitting the same question again.
    – Ramhound
    Feb 18, 2020 at 17:55
  • I understand. I'm glad we worked this out together.
    – naps1saps
    Feb 18, 2020 at 17:58

1 Answer 1

0

This was the fix:

  1. Go into the calendar owner's Outlook application or add their account to your Outlook.
  2. Go to File > Account Settings > Delegate Access.
  3. Remove the user.
  4. Re-add the user's permission to the calendar via PowerShell or GUI options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .