1

I was installing (at the stage of "copying files...") Linux Mint from a SD card with uncompressed .iso file in a USB Flash drive (it already had installed an old version of LM) when the current went off.
I couldn't install it again.

gParted does not load drives if the flash drive is already installed. I have to remove it and then plug the drive. Then it loads the device, does not show partition sde1 and all options are greyed but options
1) Device -> Create Partition.
2) Device -> Attempt data rescue
3) Format -> ext4 selected but got held despite "it might take a long time"

I tried format it in Mac and Windows unsuccessfully (as FAT32).

At Ubuntu 18.04

dmesg Summary output

sudo lsblk -f /dev/sde
[sudo] password for user: 
NAME   FSTYPE  LABEL                           UUID                                 MOUNTPOINT
sde    iso9660 Linux Mint 19.3 Cinnamon 64-bit 2019-12-13-16-58-44-00               
└─sde1 ext4    Linux Mint 19.3 Cinnamon 64-bit 0937a8f9-54d3-4705-ba68-73cb4e6bedeb 
sudo fsck -p /dev/sde1    
fsck from util-linux 2.31.1    
/dev/sde1: recovering journal    

hanged up for several hours

sudo lsblk -m /dev/sde    
NAME    SIZE OWNER GROUP MODE
sde    29,8G root  disk  brw-rw----
└─sde1 29,8G root  disk  brw-rw----

sudo mount /dev/sde1 /mnt doesn't work

 lsusb -v           
Bus 001 Device 006: ID 05dc:a83a Lexar Media, Inc. 
Couldn't open device, some information will be missing

I installed mksub. Tried options "restore to a standtard storage device" and "wipe a device" a but always the procedure got held for a long time

sudo dd if=/dev/zero of=/dev/sde bs=1M count=40 and any of dd variations get held

  • Do you need to recover any data from the USB drive? If not, it's time to get a new one. They do die sometimes. – Andrew Morton Feb 14 at 20:50
  • I don't need to recover any data. I installed Linux Mint on it 2 years ago but I used 3 times for a very short time during this period – dstonek Feb 14 at 20:53
  • It isn't clear to me if you meant that gParted option "1) Device -> Create Partition" is available because "but" means "except" in that sentence. If it is, then that's the option to choose. – Andrew Morton Feb 14 at 20:58
  • See that the partition sde1 is already created sudo lsblk -f /dev/sde as ext4 format. That option to Create Partition only has MSDOS and other non usual formats. I had tried that but also gparted freezed – dstonek Feb 14 at 21:02
  • Yes, it's not worth insisting if there's no simple solution. Actually the problem was a faulty USB connection on a laptop: one small movement and ... – dstonek Feb 14 at 21:13
1

Try the GNOME Disk Utility https://wiki.gnome.org/Apps/Disks which has been able to fix flash drives gparted could not.

  • I forgot I had Disks installed. It seems that there's no way to fix that. Tried Fix and now Format. This device turns on a blue light when it is accessed. This happens some seconds, then.... darkness! – dstonek Feb 14 at 22:56
  • 1
    Speaking of darkness, you could try using DiskPart in a Windows Command Prompt. partitionwizard.com/partitionmagic/how-to-format-ssd.html (instructions for SSD also work in this instance for USB flash drive). Again it has fixed some misbehaving USB flash drives sometimes. – K7AAY Feb 14 at 23:14
  • Also no way. I tried some options like Format, Delete partition, Wipe... After a second "operation successful" but it is not – dstonek Feb 15 at 18:45
  • As Doctor McCoy would say, "It's dead." – K7AAY 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.