While transferring data to my 2nd gen Drobo power went out. Now my Drobo is not mounting to my OS X 10.6.3

I have tried Disk Repair and this error message appears:

Verify and Repair volume “disk1s2”
Checking Journaled HFS Plus volume.
Invalid key length
Invalid record count
Catalog file entry not found for extent
The volume   could not be verified completely.
Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

I tried DiskWarrior too but it doesn't work either. It gives me that I need more memory to continue and software shuts down.

Any one know solution to this one?


This is the solution to my problem which I had with Drobo, I currently have a trouble ticket open with them and your situation looks similar. Read my last post with them.

"Although I did try some of the tools that were recommended, non of them were able to recognize the Drobo properly. I did, however, find another tool that was able to see the drive and its current file structure. The tool is called TestDisk 6.13 (http://www.cgsecurity.org/wiki/TestDisk_Download), which is an open source program for all variants of Operating Systems. TestDisk is an application that runs within a Terminal window, so it is not quite user-friendly; however, I was able to re-establish a full mount of the Drobo Disk...At least to a point where I could run Disk Warrior and rebuild the drive, which I completed successfully.

The steps I took to reestablish a connection with my Drobo are as follows: (This tool should only be used if no other tools such as Disk Warrior and Tech Tool Pro can see the drive AND the drive does not mount)

  1. Run the TestDisk application from the folder you unzipped it into.

  2. Choose [No Log] unless you require a log file.

  3. Choose [disk1] and [Proceed] -- Warning -- [disk1] is what I chose as it was the only externally connected hard drive I had (with 17TB labelled).

  4. Choose [Intel], even though the Mac uses partitions that are formatted as HFI+ Drobo Inc. uses FDISK to partition its Master Boot Record and EFI.

  5. Choose [MBR Code] - To recreate the Master Boot Record.

  6. Type "Y" for yes to accept that you are modifying the Master Boot Record.

  7. Type "Y" again to verify the change.

For the symptoms I mentioned in previous post, almost immediately the Drobo mounted on the desktop with what appeared to be the correct file structure. I ran Disk Warrior and it finally recognized the drive. I rebuilt the structure of the drive just to be safe, and I found it did have many errors on it, which were then corrected.

I then began the vigorous task of ensuring the data on the drive was still working, and I did find a few files that were corrupt, but nothing too major.

Although I was able to rebuild most of the data on the Drobo, the issue that corrupted the Master Boot Record in the first place is still at large. All I did was try to replace one bad drive, and dual disk redundancy was enabled as well, so it should have had no problem. Because the Master Boot Record is so vital to the BeyondRAID filing system, a tool should be added to the Drobo Dashboard which allows the user in such a case as mine to rebuild this sector in the event of catastrophic data failure. It does no harm to the system even if the customer does this with no real purpose. The Drobo should also be monitoring this sector on its own to ensure its structure is always intact by keeping a copy of the MBR data on different drives in Drobo/in EEPROM/and on the customers system within the Drobo Dashboard App. For this reason I keep this trouble ticket open."

Keep in mind, Drobo Inc. labeled this problem as "solved" under the trouble ticket even though it isn't. I hope this helps you out, it took hours of learning about their filesystem to finally figure it out.


Not sure if this will help, but i had a problem with my Drobo Constnatly rebooting. it was in a constant state of repair, and never lasted more than a few min mounted under Windows... This Article solved the problem. It might help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.