0

On a Windows 10 Pro 1909 (build 18363.657) mashine with one wifi- and two lan devices we try to use wifi to offer an internet connection via lan to an external sip phone. The computer is used as a Display system in public space only, showing some informations to the public. Press a call button results in a phone call via the sip phone. No other user action is possible. There is only one windows user.

PC is behind a router and firewall in dhcp mode.
Internet <> router <> PC wifi adapter (dhcp, sharingmode for ethernet01) <> PC LAN adapter (ethernet01, fixed ip address) <> sip phone (dhcp)

First we used the bridge mode of win10, it worked partly, but the connection was switched on and off all the time (every 30 sec.), caused by a 'policy' - netsh wlan report told us so EDIT: (event IDs 11004 'wifi security has been halted.' and 8003: something like 'Reason: The network is disconnected due to a policy that disables automatic connection on this interface.').

Then we tried sharing the wifi. This works perfectly, until we restart the computer. If we check the Sharing tab of the wifi device, settings are still there, but sharing it self doesn't work. The ip address of the device that is conneted to the lan port, is 0.0.0.0 - the lan port ip is fine (192.168.137.xxx).

After switching off the sharing mode and switch it on again, everything is fine - up to the next restart of the mashine.

Is there a possibility to do this automaticly, meaning deacitivate and then again acitivate this settings (the sharing mode) using some code, e.g. use powershell to set some registry entries. We tried to use netsh wlan, but could´t find a solution (there are no commands for the sharing tab).

Does somebody know if we can solve this, changing registry keys (or any other idea)?

Where is this sharing information stored in Windows? in a file, in registry keys?

Intel(R) Dual Band Wireless-AC 8260, Device drivers are up to date.

  • 1
    How many users? Can the users (small number hopefully) directly access the phone's Wireless Sharing? You may need to set up a special (this use only) computer to share out the hotspot and leave it running. – John Feb 19 at 21:58
  • 3
    What version of Windows 10 are you specifically using? Saying you are using the current version is not really enough information. There are multiple versions of Windows 10 that are considered "current". Please edit your question instead of submitting a temporary comment. – Ramhound Feb 19 at 22:40
  • 1
    Also check if IP Addresses are changing (DHCP addresses may be changing). That may be breaking the connection. – John Feb 20 at 0:37
  • @John: One Windows user, but no 'person' working at. The ip address of the sip phone stays the same (second case: sharing mode) as long as there ist no restart of the computer, but is changing after restarting the computer, I think this is 'normal behavior'. the sip phone than connects to the sip provider. – Erwin Kanns Feb 20 at 8:50
  • In my use of these devices, re-connect after restart is normal, so just plan restart and connections to suit your needs. – John Feb 20 at 11:15
0

Since the problem only occurred after restarting the computer and I could fix this problem manually by turning off and then again turning on the wireless sharing via the GUI, I was looking for a way to do this with a script.

Following the instructions at How to enable Internet Connection Sharing using command line? solved my problem. After deactivating and again activating the wlan sharing, the sip phone got a new ip address and worked as intended.

Building was tricky. First I had to install the appropriate framework (Visual Studio 2010) on the taget pc. Then I could successfully build the module.

I am using the described cmdline version, which is called in a batch file with elevated privileges via the Windows Task Scheduler at startup.

Many thanks to everyone who tried to help!

btw: I used that link above instead of a short tutorial because I assume that if that link breaks, superuser.com (where it links to) broke before.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.