0

I have a Lenovo G550 laptop. I wanted to upgrade its CPU from T3000 to P8700. Both support PGA478 socket. I bought being in use P8700 and inserted it into my G550 laptop's socket.

As a result:

  • In case of turning on, fan starts working for a few seconds and stops. Nothing appears, nothing sounds.
  • In case of unplugging power cable, it produces a short beep sound.

Then I inserted my old T3000 processor bunt did not lock it in the socket and tried to run the laptop. As a result, it reproduced situation with P8700 processor.

Then I've borrowed not supported by my GM45 chipset processor: T7500. I inserted it into my laptop's socket and ran it.

As a result:

  • Bios appeared and then with a beep or two displayed:

     CPU = 1 Processors Detected. Cores per Processor = 2
     Intel(R) Core(TM) 2 Duo CPU    T7500   @ 2.20GHz
     .....
     02F0: CPU ID: FB No Microcode Update Loaded for Alternate Processor
    
     Press <F1> to resume, <F2> to Setup
    
  • I could load Ubuntu, but only in text mode. Tried different kernels: generic, lowlatency, liquorix, xanmod. Only cursor on the black screen appeared on tty7. Ubuntu's intel microcode was the last version.

It is because of it doesn't support GM45 chipset:

Intel Core 2 Duo T7500 (Socket P) chipset compatibility
A list of compatible chipsets is based on CPU support lists, published on our website.

Intel GL960 Express   Intel GME965 Express
Intel GM965 Express  Intel PM965 Express

Their characteristics:

                      Specifications                                  Steppings
  Model / Part    Cores Threads Frequency   FSB L2     Cache    TDP C0  E0  M0  R0
Core 2 Duo P8700    2      2    2.533 GHz   1066 MHz    3MB     25W              +
Celeron T3000       2      2    1.8   GHz   800 MHz     1MB     35W              +
Core 2 Duo T7500    2      2    2.2   GHz   800 MHz     4MB     35W      +   +   

$ sudo dmidecode partial output:

BIOS Information
    Vendor: LENOVO
    Version: 18CN45WW(V2.54)         
    Release Date: 05/05/2010
    Address: 0xE5560
    Runtime Size: 109216 bytes
    ROM Size: 2048 kB

System Information
    Manufacturer: LENOVO
    Product Name: 20023               
    Version: Lenovo G550                     
    Serial Number: 2369531200637                               
    UUID: 0738b57a-69c6-11df-9934-88ae1d2ebdbb
    Wake-up Type: Power Switch
    SKU Number: Lenovo
    Family: Lenovo
    BIOS Revision: 0.69
    Firmware Revision: 0.53

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
    Manufacturer: LENOVO
    Product Name: NITU1
    Version: REFERENCE
    Serial Number: CBG2857851 

$ sudo hwinfo | grep Chipset (I deleted unnecessary data from output):

  E: ID_MODEL_FROM_DATABASE=Mobile 4 Series Chipset Integrated Graphics Controller
  <6>[    7.202904] pci 0000:00:00.0: Intel GM45 Chipset

The question:
Why the laptop with P8700 processor could not display bios and shuts down as if its CPU is not properly installed? (Actually, I don't know if it dead or not now)

Testing:

  1. Laptop is working on T3000. OS could be loaded and works correctly.
  2. Turned it off, removed T3000 and properly inserted P8700. It starts and stops without beeps and nothing is displayed on the screen.
  3. Removed P8700 and inserted T3000. It starts and works as before, loading the OS with graphics.
  4. Removed T3000 and inserted P8700. It starts and stops without beeps and displays nothing.
  5. Removed P8700 and inserted T3000 without locking it. It starts and stops without beeps and displays nothing.
  6. Locked T3000. It starts and works as before loading the OS with graphics.
  7. I borrowed unsupported T7500. Removed T3000 and inserted T7500. It starts with beeps and displays: 02F0: CPU ID: FB No Microcode Update Loaded for Alternate Processor. Ubuntu is loaded but without graphics.
  8. Removed T7500 and inserted T3000. Started without beeps, but Ubuntu loaded without graphics this time.
  9. Upgraded video drivers and rebooted. Ubuntu loaded with graphics as before and works correctly now.
  10. Friend inserted P8700 into his laptop. It is supported by his chipset. It starts, then stops, then starts again, but nothing was displayed on the screen - only battery and power indicators light.
2
  • @Gryu - While I would expect the machine to at least attempt to POST that isn't always guaranteed to happen. I am now honestly confused by your question. Before you last edit you indicate the system was working, you installed a new processor, and the system would not stay turned on. You then incorrectly installed the old processor and the machine would not turn on. You then installed the new processor and it won't stay on. At no point did you say that machine will stay turned on until your last edit. Perhaps you can edit your question to only include the current state of affairs? – Ramhound Feb 21 '20 at 17:47
  • Due to the already extremely length discussion, please do not reply with a comment, simply clarify your question. Since you have read all my comment I will be be deleting them, any and all relevant information in any of your comments, should be contained in the question. Commentary is temporary here at Super User it is not suppose to stick around forever. – Ramhound Feb 21 '20 at 17:49
1

The NITU1 motherboard supports only FSB800 Processors. I would recomend using any Penyrin processors that support FSB800. I would recomend using the T8300. The max that you could possibly do is T9500 CPU and 6GB Ram @ 1066.

1
  • Thank you for suggestion. I'll try it if I have an opportunity. But now it works with 8GB RAM. – Gryu Jul 10 '20 at 13:05
0

Today I was testing newly arrived P8600 processor and seen the same symptoms as it was with P8700 processor. Also, this time I've guessed to check GPU chip label and read there GL40.

So Lenovo G550 with GL40 chipset does not support P8600 and P8700 processors at all, but T7500 supports them partially, complaining about microcode.

P8600 and P8700 also have higher FSB frequency. Maybe it is the cause laptop could not even start BIOS with them.

Most probably the P8700 is not dead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.