2

We have some 10/100 Ethernet devices with intermittent power-up connectivity loss when connected a various Gibabit Ethernet switches.

  • We have tried multiple identical devices, with the same results.
  • The devices are set with a static IPs, on a local-to-the-system subnet.
  • Initially, the devices were connected via Ethernet to a TrippLite NG16 un-managed gigabit switch.
  • The power supply, devices, and switch are powered from the same AC source, and are physically in the same apparatus.
  • The AC source may be switched on/off with a main toggle switch.

There are many Ethernet devices on the connected switch (perhaps 10).

The interfaces range from gigabit (control computer) to 10/100 (both commercial and in-house gadgets). None of the devices currently need to be able to achieve gigabit speeds.

Sometimes some or all of the 10/100 devices cannot be found after a power-up. Connect LED's on the Ethernet jacks are only sometimes illuminated.

So, we did some experimenting making our device connections with different Ethernet switches, and then tested for connectivity after power-up:


Allied Telesis AT-FS708 (10/100) Success
100% Success rate. This switch has a long working history with us.

TrippLite NG16 (Gigabit) Failure
Randomly fails initial connection for each power-up.

TrippLite NG24 (Gigabit) Success
100% Success. A dozen reboots or so. Many unneeded ports for our system.

Netgear GS724TP (Gigabit) Failure
A managed switch we had around. Failures for some of our slow devices. However, it was possible to reliably get coms working by turning off auto-negotiating, and applying manual settings for individual ports.

Netgear JGS524 (Gigabit) Failure
100% Failure for a specific commercial device! Worked with some other slow devices.

Netgear JFS524 (10/100) Success
100% Success rate. A dozen power cycles or so. Slower brother of the other Netgear JGS524 above.

HP 1420 (Gigabit) Success
100% Success rate. A dozen power cycles or so.


I'm wondering if anyone in the user base has encountered issues with various switches, and perhaps has determined what to look for in order to avoid compatibility issues.

I am not looking for specific product suggestions!

Perhaps this is this a switch issue, cabling quality/type issue, or a device interface issue?

Some devices that fail to connect are designed by us (so, we can adjust the electrical interface, if needed). However, other failed devices are commercial devices, where modification is not as easy.

Suggestions?

10
  • Do you know whether the switches run Spanning-Tree Protocol? Commented Feb 21, 2020 at 17:10
  • this sounds very much like the gigabit switches are not to blame, but your 10/100 Mbit devices. My guess is that they somehow misbehave; what kind of devices are they, in particular? what manufacturer made the ethernet MACs on these? In particular, these devices simply might send incorrect data during autonegotiation – a problem I haven't seen in the wild since ca 2000. Commented Feb 21, 2020 at 17:16
  • @MarcusMüller The commercial product uses a Microchip LAN8720A: https://www.microchip.com/wwwproducts/en/LAN8720A. Our devices tend to use a Wiz5500: https://www.wiznet.io/product-item/w5500/. Commented Feb 21, 2020 at 18:26
  • @user253751 Frankly, I have no idea. I had to look up STP on Wikipedia, and I'm still not sure how to tell, or if it even applies. Commented Feb 21, 2020 at 18:31
  • 1
    1) Looks like wrong MDI/MDIX detection on direct-wired cable. 2) Does your devices are not PoE?
    – Akina
    Commented Feb 21, 2020 at 19:41

1 Answer 1

1

Our solution: Use what works.

We've been using the HP 1420 since posting this question, and it has worked with every power-up.

So... Buyer beware. Old/slow Eth gadgets may have power up issues (likely due to power-up timing with Auto-negotiatation?), with some newer/faster switches.

Good luck everyone.

-Chris

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .