2

For some reasons I have to use VirtualBox Version 5.2.

I also need the Guest Additions plugin.

When I ran vagrant plugin install vagrant-vbguest, it installed vagrant-vbguest-0.23.0 for me.

When I start up the box, I saw these messages:

GuestAdditions are newer than your host but, downgrades are disabled. Skipping.
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default:
    default: Guest Additions Version: 6.1.2
    default: VirtualBox Version: 5.2

I have tried the following but it failed:

$ vagrant plugin install vagrant-vbguest --plugin-version 5.2.0
Installing the 'vagrant-vbguest --version '5.2.0'' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Unable to resolve dependency: user requested 'vagrant-vbguest (= 5.2.0)'

I am led to believe the plugin has a different versioning scheme. It is because when I uninstalled the plugin, the log showed:

$ vagrant plugin uninstall vagrant-vbguest
Uninstalling the 'vagrant-vbguest' plugin...
Successfully uninstalled micromachine-2.0.0
Successfully uninstalled vagrant-vbguest-0.23.0

So the Guest Addition version 6.1.2 is actually 0.23.0 in some remote repository?

So what is the right version number of Guest Additions in this case? I bet it is possibly 5.2.x but what is x? How can I find out?

2
  • Why don’t you just upgrade VirtualBox to the current version?
    – Ramhound
    Feb 24, 2020 at 12:41
  • It is the constraint of my development environment at work. Feb 24, 2020 at 12:42

1 Answer 1

3

It is a bit late, but have you tried to force the installation?

After you ran

$ vagrant up

you could try to run

$ vagrant vbguest --do install

this may force to install the correct version.

Reload the vm after this command

$ vagrant reload

to check if both systems running the same version use

$ vagrant vbguest --status

I hope this may help. Even if time went by and you may already have a solution :D

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .