1

Hi I have a PC with a proxy internet connection. When I use for example flutter it needs to download some dependencies by sock connection. How can I set a global configuration for my PC to use socks connection to internet? Thanks

3

Windows' basic proxy settings in "Network and Internet" don't seem to actually allow setting a SOCKS proxy explicitly.

To set a SOCKS proxy (SOCKS4 or SOCKS5, I believe) on Windows 10:

  1. Take note of your public IP address by searching Google for "my ip" (open this in a new tab and keep it open)

External IP address from Google

  1. Open Internet Options (either by searching in the start/search bar, or through Control Panel > Network and Internet > Internet Options)

Open internet options

  1. Open the Connections tab and click LAN Settings

Connections tab

  1. Check the box to "Use a proxy server for your LAN". You'll likely also want to check "Bypass proxy server for local addresses". Then click the "Advanced" button: LAN Settings

  2. Uncheck "Use the same proxy server for all protocols", remove all proxy addresses except for "Socks", and replace the Socks address/port with that of your server:

Advanced Proxy Settings

  1. Click OK on the Proxy Settings window, OK on the LAN Settings window, and Apply on the Internet Properties window. All connections should now be going through your SOCKS proxy. Double check by again searching Google for "my ip" and comparing to your original external IP address (this should now show the IP address of your SOCKS5 server)

New external IP address reported by Google

Credit to https://windowsreport.com/windows-10-socks5-proxy-settings/ for getting me pointed in the right direction, after trying the suggestions on this page

2
  • Thank you. This is the only solution that worked for me. The more modern Proxy Settings dialog mentioned in the other answers was not effective. Enabling the proxy there did nothing and when the dialog was closed and re-opened it still showed the proxy was "off".
    – naudster
    Mar 4 at 23:19
  • @naudster yeah, that's what I found too. Certainly kinda strange how all the new settings dialogs just seem to be wrappers around the seemingly-unchanged Windows NT settings interfaces. Would be nice if the whole system worked together, but I guess better that than only having the semi-broken pretty new interface 🙃 Mar 7 at 13:46
1

If you use Windows 10, follow the steps below to set proxy:

  1. Open Settings.

  2. Click Network & Internet.

  3. Click Proxy.

  4. In the Manual Proxy Setup section, set the Use a Proxy Server switch to On.

  5. In the Address field, type the IP address.

  6. In the Port field, type the port.

  7. Click Save; then close the Settings window.

enter image description here

There is 4 main types of proxy:

  • HTTP — allows to visit web-sites and download files from HTTP.
  • HTTPS — also called SSL proxies. With these proxies you can view HTTP and HTTPS sites.With special software they may be used with any protocol like SOCKS proxies.
  • Socks 4 — can be used with any TCP/IP protocol with any destination address and port..
  • Socks 5 — you may also use UDP protocol, make DNS requests, und use BIND function for port forwarding.
10
  • 1
    I did that. But I have a socks error when I use flutter.
    – AGHA
    Feb 25 '20 at 15:20
  • Then your sock/proxy doesn't work, or couldn't connect. Which one you use? A proxy server from a website, or SSH?
    – Mike D
    Feb 25 '20 at 15:30
  • Well, I am not sure about this. I guess that it is a proxy server from a website. I just know that my proxy is a IP:port. Sock is a proxy feature?? Is possible that my proxy works ok with http protocol and not works with sock protocol?? Thank.
    – AGHA
    Feb 25 '20 at 15:47
  • It's possible. You can go to hidemy.name/en/proxy-list and get a few other proxies to test whether it's work or not.
    – Mike D
    Feb 25 '20 at 15:51
  • I've edited the answer with the information regarding types of proxy, take a look at it!
    – Mike D
    Feb 25 '20 at 15:57
1

The only way I was able to set a socks proxy in windows 10 was via Internet Explorer.
Search for and run the Internet Explorer App.
From the Tools menu click on Internet Options. Click on the Connections tab. Click the "LAN settings" button. Add a check to the "Use a proxy server for your LAN" if its not already checked. Click on the Advanced setting Uncheck the box for "Use the same proxy server for all protocols" if it's checked. Set your SOCKS server here and clear the fields for all the other proxy types. Click OK, click OK, click OK, and now your system is configured to use a SOCKS proxy.

1

The Windows 10 proxy setup UI is terrible.

To use socks, you need to enter this into the address field:

http://socks=localhost

Replace localhost with the actual proxy address.

Set the port as per usual.

1
  • Hrm, this doesn't seem to be working... afaict this is just causing windows to ignore the proxy setting completely (unlike just putting in localhost, which causes the connection to fail completely) Jan 17 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.