I am looking at purchasing a Mac mini to help with development of a flutter application. The newest versions are quite expensive and after looking on ebay the cheaper versions are the 2011 models.

The hardware is primarily 2.3 GHz i5, 8gb ram and SSD which seems fine but the OS version varies from mountain lion to High Sierra. I assume older versions can be updated?

I can't find anywhere that specifies minimum OS versions for flutter. Does anyone know whether a 2011 Mac mini would be appropriate for app development. I would like to also use the IOS emulator with newer apple device/phone models and iOS versions.

Sorry I have little experience with Mac os. Thanks a lot


Flutter's minimum requirements themselves are pretty basic & not really OS-dependant.

Xcode, on the other hand, requires you to be pretty much up to date with the current macOS. There is some leeway, but not much.

Xcode 11.4 requires a Mac running macOS Catalina 10.15.2 or later.

The 2011 can be updated - for free - however, can only be updated to High Sierra 10.13.x which does not meet the minimum requirements for Xcode.

If you want to do this on a Mac Mini you'll need a 2014 or newer.

  • Do you think apple will provide backwards compatibility over the next few years for the 2014 mac mini models? – ebg11 Feb 29 '20 at 20:25
  • Apple tends to give 5 years mainstream support, followed by 5 years 'limited' [security updates etc, still stock spares]. After that, they become obsolete. The 2014 is already halfway down that path, so I'd expect it to be dropped from full support sometime in the next year or two. They tend to drop models in batches, as one part of their technology becomes 'too old' to use a new structure. Metal was the last such change, before that full 64-bit efi. – Tetsujin Mar 1 '20 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.