1

I'm lost on this one. I've been farting around in the registry for days, and asking on general type forums like tenforums.com

So far no luck.

I've set txt files to open with my portable notepad++ and changed the edit from notepad to notepad++

I've done it across the board for just about everything text related. No problems. Most items, even batch files retain right click > print in the context menu.

I dabbled with changing that over to notepad++ (the print command) but since it doesnt have printto built into it, and i didnt want to deal with disabling line numbers to print - i decided to leave the print command pointing to notepad.

The glaring issue is that right clicking on txt files now I dont have the option to print period. How can i get it back into the context menu using notepad same as if by default?

1
  • Did you try the associate feature in Notepad++ itself? – shawn Mar 3 '20 at 5:41
0

You have lost Print command since it is associated with the file type txtfile. You can check the file type association in the windows explorer as shown below:

enter image description here

Take a look at the Registry entry below.

Notepad Print Context Menu

There is a Print command associated with any file that have file type txtfile. Notepad has a switch /p that can print the document from the command line. You can test it by typing:

notepad /p myFile.txt

Notepad++ do not have such switch from command line. So, it may not be possible to do that in Notepad++.

Hope it helps.

1
  • 1
    -quickPrint to print from notepad++ aka "path\to\notepad++.exe" -quickPrint "%1" afaik none exists for printto yet however. – klepp0906 Mar 3 '20 at 23:25
0

I actually figured out where the issue lay. notepad++ didnt have print associated by default, even though i associated txt with notepad++ and open worked fine etc.

I was able to add print here

HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\print\command

and notepad++ does have a switch to print now. -quickPrint

it doesnt have one for printto but i can live without that.

Thanks for the replies and sorry about the formatting. im brand spanking new to superuser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.