0

My mom was writing a text in Office Word and she wanted to save it on her USB device. She says that the computer was trying to save it for a long time and then a text popped up (she didn't read it carefully and doesn't remember what it said) and in upper left corner, next to the document name, it said ''Not responding''. She closed the pop-up window and continued to write the text for approximately 20 minutes. During this period she continued saving the file over and over successfully and made a copy of it on desktop.

Then she tried searching for another file on the same USB device. She opened a folder which should contain about 10 subfolders and some documents. The subfolders were all gone but one (she thinks it might have been a folder with an unknown name, but again she doesn't remember), but all the documents were there plus one unknown document (she says it looked like an autogenerated document).

Then she went to This PC where she found her USB device but the bar which shows how much memory is left on it was red for the first time (there is only 1 GB left on the device). After that she pulled the USB device out of the computer.

Here comes the weird part. I've tried inserting the USB device into three different computers and a smart TV afterwards. All of them recognized the device only for a couple of seconds. It was enough for me to see that the main folders are still there and I saw on Disk Management that there is 15 GB of memory saved on the device which is correct. Then I tried inserting the device into the same computer, but this time Disk Management said there is 15 GB of unallocated memory and the disk disappeared after a couple of seconds again. The third time, it didn't disappear and disk management showed the disk but it said that there was no media. That time the device also appeared in This PC section but there was no memory displayed beneath the name of the disk as it usually is.

It's a very important USB device because most of my mom's work is saved on it and she backed up only the most important documents so I don't dare to guess what to do because I'm afraid of losing the documents permanently.

What could be the reason why the USB device isn't recognized and how can I solve this problem?

3 Answers 3

0

I would suggest two things as a starting point..

1.I would go to device manager and remove the device and drivers. This can be done by simply right clicking on the device and clicking "Uninstall Device" and checking the box that says "Delete the driver software for this device". Once this has been done, restart the computer, and then insert the USB in to the computer and allow Windows to detect the device and install the drivers.

2.If this option does not work,I would try using the "CHKDSK D: /R" (D: being the volume label of the USB).This command will check the designated drive and try to find and fix any bad sectors on the drive.

Hope this helps..

0

It can't be a problem with your computer or your drivers since this happens in every computer you connect this flash drive to. Seems like that flash drive is damaged or expired.

Try These:

  • If you can read those documents in any other computer even for few seconds, try to take them out one by one. There's not much you can do if the device won't stay connected. Try connecting it to different computers. If you have a Linux computer, try it.
  • Also maybe that flash drive has corroded connections. Try to clean the connections in the USB head of the flash drive and the USB female connector in the computer using some rubbing alcohol.

Never keep important documents/media on flash drives or SSDs. If you use a flash drive to carry important data around, make sure you have a backup of those files in a Hard Drive. Because most of the time you can recover data from a dead hard drive but it's very hard or impossible to recover data from dead flash memory.

0

I don't want to be a party pooper but the UFD is probably failing (the NAND).

Do NOT run chkdsk or anything else that potentially writes to the drive, repairs the drive etc.. This is golder rule when it comes to data recovery and again it is my estimate this is not a logical issue.

Your best option would be a lab. I know this may sounds overkill if you can still see your files, but non the less. They have specialized tools to clone such drives.

If you want DIY, you can get one of those ($35) https://www.yepkit.com/product/300115/YKUSHXS

There are two clone tools that can control it that I know of, HDDSuperClone (I do not know if the free version will control the YKUSH device) and JpegDigger. JpegDigger free version can be used. Demo: https://youtu.be/ggNTCRzT7qw?t=831

Idea is to power-cycle the UFD and then continue cloning.

I have done this many times and it works. But a lab can do it smoother using more sophisticated tools like DeepSpar USB Stabilizer as the OS will not even be aware the drive dropped, plus it allows for controlling read timeouts and reset protocols. Demo: https://youtu.be/XcOUVsIfwwo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.