1

I have recently bought a Lenovo P53. Since I needed docking station and thought that the Thunderbold3 dock was to OP for me, I bought the smaller USB-C dock.

I know that you can't power the P53 (170W EU version) via USB-C, however I have the original Power Supply connected to the laptop.

Yesterday this setup was working perfectly, however after starting up today for the second time, I keep getting notifications, that the PC isn't charging via USB. This is even though 1. the original Power Supply is still connected, 2. the battery is at 100% and 3. the charging icon in the taskbar is shown nonetheless.

Windows being Windows, if you click on the notification you are directed to their site suggesting to turn of these USB related notifications. However, I don't just want to turn off the notification, I want to solve the underlying issue.

How can I tell my Notebook, that I don't want it to charge via USB-C if the original Power Supply is connected?

5
  • Have you checked the OEM support site and UEFI firmware settings?
    – JW0914
    Mar 10, 2020 at 11:55
  • @JW0914 Well, since I recently had the "pleasure" of dealing with the OEM support, I wanted to avoid it at all costs ;) UEFI settings: I'll check, if I find a corresponding option Mar 10, 2020 at 14:41
  • Since this is a model-specific question, the information will likely either be in the PC's manual or on Lenovo's support site.
    – JW0914
    Mar 10, 2020 at 16:03
  • It sounds like a bug in the system power management firmware. It looks like the Type-C port, when connected to dock, tried to negotiate as power consumer asking ~100W, and your "smaller dock" failed to meet the contract. So the OS flagged this. However, the dedicated power input should disable any power negotiations over Type-C (laptops don't "combine power" from two sources). This is a bug. Wait for next BIOS update, they might fix this. Mar 30, 2020 at 0:48
  • If you keep the external power, then disconnect Type-C and plug it back, do you still have the warning? Mar 30, 2020 at 0:50

1 Answer 1

0

As it turns out I found an answer given by the Lenovo tech support (which in this case was really fast and helpful!):

Turns out the Windows Quickstart feature didn't let the docking driver start, which led to the problem. After turning it of, my laptop needs a tiny bit longer to start up, but the issue is resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.