1

After my D-Link 2730u router kept disconnecting, I checked the dlink website and found out that there's a firmware upgrade with name "DSL-2730U-ADSL-Disconnect", so I gladly downloaded the files, which had this readme.txt inside saying:

WARNING: 1.DO NOT use wireless connection for firmware upgrade to avoid damaging your router! 2.DO NOT use Wizard for Internet & Wireless Setup!

Step 1: Download the DSL-2730U FIRMWARE to your desktop computer / notebook.

Step 2: Login to the device web management interface (Default IP address: http://192.168.1.1). Go to Maintenance -> Firmware Update.

Step 3: Browse for the firmware that you have just downloaded on your desktop. Click "Update Firmware" and wait for the DSL-2730U to finish upgrading. Router will reboot.

Step 4: After upgrading, do a factory reset on DSL-2730U to clear away any unwanted settings left behind from the previous firmware. To factory reset the router: Press the "RESET" button at the back of the device. or Go to Maintenance -> Settings and click "Restore Default Settings". Router will reboot.

Step 5: After router rebooted, login to the device web management interface. On the top right corner, the firmware version should show "TH_1.00B". If you do not see this, go back to STEP 2 and try the upgrade process again.

Step 6: You may reconfigure your ADSL setting via the QIG "Manually Configuring PPPoE Connection on the DSL-2750U-2730U-thai-english.pdf".

So, taking the advice, I connected the router through a LAN wire, went to the admin panel, uploaded the firmware, waited, kept waiting for minutes, checked out the leds on router, and they all turned off but the wireless led. Kept waiting for minutes. Figured out maybe the reboot was unsuccesfull or something. Tried to get back to the admin panel but no luck. So I just turned the router off, and a few minutes on again, except, the power on led was still off. Actually, non of the leds lighted up. Freaking out, went to many forums, reading about this "Emergency Flashing the Router", but no luck.

The thing is, the leds won't light up no matter how long I kept the reset button pushed before/during/after plugging the router back to power socket.

Has anyone ever experienced something like that? Is there any way I can UNBRICK this device since I'm not able to replace it? I do have access to "ARDUINO" and serial cables, but didn't have the gut to try flashing it this way yet.

[sigh] ... is there any hope?

Model No: DSL-2730U

H/W Ver. : C1

F/W Ver. : LN2_1.00

  • Try to factory reset the router as described in the manual on page 17. – harrymc Mar 10 '20 at 20:56
  • @harrymc Thanks, I tried but no luck. 10 seconds, 20 seconds, 30 ... . I have done the reset to factory procedure with this modem before. However, this time, it doesn't work the same way it used to do :/ – Pedram Ashofteh Ardakani Mar 11 '20 at 8:46
  • Get in touch with the manufacturer and ask for a solution. If you downloaded the firmware from their website, then it is their responsibility. – harrymc Mar 11 '20 at 8:49
  • @harrymc Will do. Thank you. – Pedram Ashofteh Ardakani Mar 11 '20 at 8:54
  • 1
    @Tim_Stewart Thank you for pointing this out. However, I waited more than just 5 minutes. I followed the instructions and got stuck in step 3. The modem never rebooted by itself. I did not witness any blinks indicating that the modem is working. After waiting for a while, I rebooted it manually which was not a good decision. I will try setting the static IP again. I will let you know if things work out. Cheers. – Pedram Ashofteh Ardakani May 25 '20 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.