14

I am trying to set up a VNC connection from my PC (Ubuntu 18.04) to a headless (I can use only terminal) Raspberry Pi zero w (Rasbian 2020) using Remmina, but I am getting the error window:

Unknown authentication scheme from VNC server: 13, 5, 6, 130, 192

I have installed vnc in the raspberry and started it with vncserver :1. It gave me an IP-like thing. Then I have set a password with sudo vncpasswd -service and with vncpasswd -user using the same password. Then I tried to connect from the Ubuntu (PC) by using Remmina with the following credentials:

Server: [the IP-like address]

Repeater:

User name: [my_username]

User password: [server_or_user_password]

I tried both passwords, adding the line Authentication=VncAuth to the end of .vnc/config.d/vncserver-x11 and disabling encryption. In all cases, Reminna opens the error window and I can't connect.

1
  • Worked for me with the steps for the question. Dec 5, 2020 at 21:23

4 Answers 4

10

I tried both passwords, adding the line Authentication=VncAuth to the end of .vnc/config.d/vncserver-x11 and disabling encryption

Modifying the .vnc/config.d/vncserver-x11 file changes how vncserver runs in service mode. These settings are ignored if you launch vncserver directly. Given that you're starting vncserver as follows

I have installed vnc in the raspberry and started it with vncserver :1

it means that the authentication method for that vncserver instance will not be using Authentication=VncAuth but instead the default (which Remmina doesn't understand).

To resolve this problem, start vnc server as follows:

$ vncserver -Authentication VncAuth :1

Note that these arguments are case sensitive (and doesn't always give useful error message if you get it wrong).

1
  • This can be accomplished for the vncserver that runs on the 'desktop' of the Pi (if you have a monitor hooked up) by clicking on the VNC server icon in the system tray, going to options and changing the Authentication to 'VNC Password' and then setting a password on 'Users and Permissions' tab in options. Dec 5, 2021 at 13:23
6

A bit neater write up on the same under the link below. Tested against default VNC server on Raspberry Pi 3 running Debian 11 (Bullseye).

https://docs.linuxconsulting.mn.it/notes/remmina-vnc-raspberry

====== Connect to Raspberry Pi OS via VNC using Remmina ======

-- //Tested with Raspberry Pi OS on July 2020// --

When trying to connect from your Linux machine using Remmina to a Raspberry Pi running Raspberry PI OS with RealVNC enabled you get the error

  Unknown authentication scheme from VNC server: 13, 5, 6, 130, 192

RealVNC only supports a few security schemes. Authentication=VncAuth seems to be the only scheme that allows direct connections from VNC-compatible Viewer projects from third parties. In order to change to VncAuth scheme in your Raspbian and set a password to accept connections from Remmina VNC plugin, open a SSH session (or a terminal window) on the Raspberry and generate your VNC password with:

sudo vncpasswd -service

Now, edit the file /root/.vnc/config.d/vncserver-x11

sudo nano /root/.vnc/config.d/vncserver-x11

and add the following line at the end of the file:

Authentication=VncAuth

Now your config file should look more or less like mine:

  _AnlLastConnTime=int64:0000000000000000
  _LastUpdateCheckSuccessTime=int64:01d65c12272dff1a
  _LastUpdateCheckTime=int64:01d65c12272dff1a
  Password=c3abbea3b003a0b231737c0541892d72
  Authentication=VncAuth

c3abbea3b003a0b231737c0541892d72 is the encrypted version of ''raspberry''; your line will be different.

Eventually, restart the VNC server service with

sudo systemctl restart vncserver-x11-serviced

and you are ready to connect to you Raspberry Pi using Remmina.

4

I know this is an indirect solution for the above error. This will install Real VNC Viewer and use this to create a working VNC connection out of the box.

Download the Real VNC Viewer from here. After installing and starting the program, I had to put the Domain (The raspberry IP and not the "IP-like thing"), the username and the user password.

The installation was done on the command line using:

wget https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-6.20.529-Linux-x64.deb
sudo dpkg -i VNC-Viewer-6.20.529-Linux-x64.deb 

Tested on Ubuntu 18.04.

1
  • Works on Ubuntu 20.04.2 too
    – Jeni
    Apr 7, 2021 at 20:10
1

Firstly, I think that this question belongs to the raspberry pi exchange.

Secondly, you probably need to disable encryption in remmina connection settings.

3
  • I already tried disabling the encryption without success. I am updating my question right now. It's more of a question about VPN. I mentioned raspberry in order to mention raspbian, although it's is a Debian.
    – Phineas
    Mar 15, 2020 at 10:30
  • Have you done sudo vncpasswd -service for setting a password for vncserver?
    – rktech
    Mar 15, 2020 at 10:47
  • Yes I have. I already stated it in the question
    – Phineas
    Mar 17, 2020 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.