0

I had to nuke my computer and reformat my hard drive because of a virus and i copied a snapshot of my VirtualBox VM. I made the mistake of not cloning and just copied the vdi file from the snapshot folder. Now i'm trying to create a new VM with the vdi file and get this error:

Parent medium with UUID {178c8048-144b-4dcf-a1ad-b661402a911a} of the medium 'C:\Users\Ethan\VirtualBox VMs\aluminis{d1676259-419a-47cc-aac5-3f4c32a0e0da}.vdi' is not found in the media registry ('C:\Users\Ethan.VirtualBox\VirtualBox.xml').

Result Code: E_FAIL (0x80004005)
Component: MediumWrap
Interface: IMedium {ad47ad09-787b-44ab-b343-a082a3f2dfb1}
Callee: IVirtualBox {d0a0163f-e254-4e5b-a1f2-011cf991c38d}
Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)

I tried running internal commands to set the parent uuid:
VBoxManage.exe internalcommands sethdparentuuid "C:\Users\Ethan\VirtualBoxVMs\aluminis{d1676259-419a-47cc-aac5-3f4c32a0e0da}.vdi" {178c8048-144b-4dcf-a1ad-b661402a911a}

I got the confirmation that the UUID had changed, but i'm still getting the error.

9
  • Can you create a new VM just like the old one and at the appropriate point, import the old VM. You may also be able to locate the old VM in the new folder and just open it.
    – anon
    Commented Mar 14, 2020 at 23:19
  • That's what i meant when i said i created a vmi and tried using the vdi file, I stil get the same error.
    – Plee
    Commented Mar 14, 2020 at 23:54
  • Did you use exactly the same settings as the old one machine? Memory, number of processors and so on?
    – anon
    Commented Mar 14, 2020 at 23:59
  • Yes I did, but before I could even install the vm, virtualbox wouldn't let me even open the file
    – Plee
    Commented Mar 15, 2020 at 0:05
  • 1
    A snapshot is not a true copy. So as I noted, you will probably have to start again
    – anon
    Commented Mar 15, 2020 at 1:25

0

You must log in to answer this question.

Browse other questions tagged .