1

I keep having a very unstable wifi connection. Would be very helpful if someone could point out the direction to look into.

Let me first explain my setup.

  1. Router/Modem from ISP. In bridge mode.
  2. Router 1, connected on LAN port from ISP Router/Modem, IP: 192.168.1.1, DHCP = ON (range 192.168.1.10 and upwards). Channel auto. This router is a dual band router, both frequencies have their own SSIDs.
  3. Netgear Switch (connected on LAN port from Router 1).
  4. Router 2, IP: 192.168.1.2, connected with switch through LAN port. Channel auto. DHCP = Off. Single band. different SSID again.

Some notes:

My internet speeds are very slow. Once I reboot Router 1 or the modem, it is fine for like 30 mins. After that I am on 1-10 Mbps.

What I tried so far:

  1. Connecting directly though ethernet to Modem/Router from ISP: 250

  2. Mbps stable Connecting to Router 1 directly though ethernet: 1-50 Mbps

  3. Connecting to Router 2 directly though ethernet: 1-5 Mbps.
  4. Connecting to switch though ethernet: 250Mbps
  5. Wifi Router 1: 1-50 Mbps.
  6. Wifi Router 2: 1-5 Mbps.
  7. Once I reboot router 1 or the ISP router/modem everything is on 200 Mbps or above (as it should be.

Is the switch inbetween router 1 and 2 maybe causing the issue?

| improve this question | | | | |
  • What link speed (i.e. 10 Mbps or 100 Mbps or 1 Gbps) do the LEDs on the switch indicate? Similarly, what link speed does Router 1 show in its settings screen (for both the connection towards ISP router and the connection towards the switch)? – user1686 Mar 16 at 13:02
  • Input for the switch from router 1 is 1Gbps. Output for the switch (going to router 2) is 100Mbps). I don't think I can determine the link speeds in the Router 1 settings, or should I be able to? – G Joziasse Mar 16 at 13:24
  • Just checked one more thing: Connecting to switch though ethernet: 250Mbps – G Joziasse Mar 16 at 13:40
  • @GJoziasse You need to select actual channels for the WiFi radios, else poor performance will occur (it's likely DFS is forcing your WiFi radios onto suboptimal channels due to being left on auto, which is why auto is not recommended). If in the US, 5GHz generally gets the best performance on channel 157. For the 2.4GHz, channels 1, 6, or 11 should be used, however, to determine which one, use WireShark, InSSIDer, etc. to review the networks near you and choose one of those three that has the least amount of radio utilization. Once done, reboot your router. – JW0914 Mar 16 at 13:56
  • I've just did a hard reset on all routers and set everything up from scratch. Should the channel of router 2.4 Ghz be te same channel as router 1 2.4 Ghz? Better separately am I right? Router 1 2.4 is now on channel 6 and router 2 2.4 is on 11. – G Joziasse Mar 16 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.