0

I am using a MacBook Pro (15-inch, 2017) with macOS 10.15.4 Beta (19E258a). I cannot connect to any Wi-Fi network.

I ran a complete scan of my disk with the antivirus program 'Virus Scanner Plus' and removed all malware. Then I tried booting in safe mode, and the ping command, to this result:

tommy@MACBP-5 ~ % ping google.com
ping: cannot resolve google.com: Unknown host

Please help me connect to my Wi-Fi.

EDIT1: I tried all the methods suggested by @ParthShah: 1. Updating my laptop's software: Couldn't check for updates. 2. Disabling Wi-Fi then enabling it: Didn't work. 3. Restarting my modem and router: Didn't work. 4. Restarting my laptop and booting into Safe Mode: Didn't work. 5. Creating a new network location: Didn't work. Also, I tried the ping command again, which yielded the same result as above.

EDIT2: I can check for software updates via System Preferences (i.e. connecting to the Apple Software Update Server (swscan.apple.com)), but nothing except that.

EDIT3: @GordonDavisson, I can connect to the Wi-Fi network, but I can't connect to the Internet. (I have edited the title of the question according to this.) The system interface shows the info of the network, like so: System information of Wi-Fi network And 'iStat Menus 6' shows the information, too: iStat Menus 6: Network iStat Menus 6: Network Information

But, I can't connect to the Internet. This issue is with my MacBook Pro only; My Surface Laptop i7 can connect to the Internet perfectly well.

EDIT4: @GordonDavisson

tommy@MACBP-5 ~ % cat /etc/resolv.conf
#
# macOS Notice
#
# This file is not consulted for DNS hostname resolution, address
# resolution, or the DNS query routing mechanism used by most
# processes on this system.
#
# To view the DNS configuration used by this system, use:
#   scutil --dns
#
# SEE ALSO
#   dns-sd(1), scutil(8)
#
# This file is automatically generated.
#
nameserver 10.100.0.1

EDIT5: @GordonDavisson

tommy@MACBP-5 ~ % scutil --dns
DNS configuration

resolver #1
  nameserver[0] : 10.100.0.1
  if_index : 15 (utun1)
  flags    : Supplemental, Request A records
  reach    : 0x00000027 (Reachable,Transient Connection,Connection Required,Automatic Connection On Demand)
  order    : 101600

resolver #2
  nameserver[0] : 10.100.0.1
  if_index : 15 (utun1)
  flags    : Request A records
  reach    : 0x00000027 (Reachable,Transient Connection,Connection Required,Automatic Connection On Demand)
  order    : 200000

resolver #3
  domain   : local
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300000

resolver #4
  domain   : 254.169.in-addr.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300200

resolver #5
  domain   : 8.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300400

resolver #6
  domain   : 9.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300600

resolver #7
  domain   : a.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300800

resolver #8
  domain   : b.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 301000

DNS configuration (for scoped queries)

resolver #1
  search domain[0] : kornet
  nameserver[0] : 192.168.1.1
  if_index : 5 (en0)
  flags    : Scoped, Request A records
  reach    : 0x00020002 (Reachable,Directly Reachable Address)

resolver #2
  nameserver[0] : 10.100.0.1
  if_index : 15 (utun1)
  flags    : Scoped, Request A records
  reach    : 0x00000027 (Reachable,Transient Connection,Connection Required,Automatic Connection On Demand)

EDIT6: @GordonDavisson The Networks pane in System Preferences

EDIT7: @GordonDavisson ANSWER FOUND! The VPN was causing it. (The service 'VPN Unlimited')

  • Exactly how does it fail? Do you see wireless networks under the Wi-Fi menu item? If so, what happens when you choose one? – Gordon Davisson Mar 17 at 5:23
  • (Please see edited question for details.) – tommyaq Mar 17 at 5:44
  • That looks like the Wi-Fi part is working ok, there's something wrong elsewhere in the network setup. You said you removed malware... what was on it? Also, run the Terminal utility, and run the command "cat /etc/resolv.conf" -- it should have several lines of "macOS Notice" followed by something like "nameserver 192.168.1.1" – Gordon Davisson Mar 17 at 5:55
  • I removed the file known as Trojan.MAC.Generic.4753; Also, cat /etc/resolv.conf yielded the result shown in EDIT4. – tommyaq Mar 17 at 5:59
  • Check System Preferences -> Network pane -> Advanced button -> DNS tab. Is that "10.100.0.1" listed on the left? If so, remove it (select it, then click "-" under it), and it should switch to a greyed-out "192.168.1.1". Then click OK and then Apply to actually make it change. – Gordon Davisson Mar 17 at 6:11
0
  1. Update your Mac if there is an update available. You can check that by going to the Apple menu > About This Mac > Software Update.

  2. Disable Wi-Fi (you can do so by clicking the Wi-Fi icon and selecting ‘Turn Wi-Fi Off’ in the menu bar) and wait a few seconds and then re-enable it.

  3. Restart everything:

    • Restart your Mac by going to the Apple menu and Restart
      Restart your modem and router
  4. Create a new network location

    • On your Mac, click the Apple menu
    • Click System Preferences
    • Click Network
    • Click the Location drop-down menu (This says Automatic unless you changed it before)
    • Click Edit Locations
    • Click the plus (+) sign to add a new location
    • Rename the new location if you want
    • Click Done And click Apply (Network pane).

    Now try to test if your Internet problem is resolved.

Check the link for more details: https://macreports.com/mac-catalina-wi-fi-problems-fix/

| improve this answer | |
  • Oops. That didn't work. (See edited question for details.) – tommyaq Mar 17 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.